Toad World® Forums

Error Starting TDM 3 BETA


#1

Hello,

If you encounter similar problem on starting up TDM 3 BETA:

“Access Violation at address 0012FE93. Write of address 0012FE93”

please read this text:

Our developers have created a special executable file.
Please follow these steps:

  1. Download the TDM3.exe file from the following location:
    http://modeling.inside.quest.com/shares/modeling/sbin/download/tdm3_exe_with_log.zip (5 MB)

  2. Extract the TDM3.exe file from the ZIP package.

  3. Copy it to your TDM3 BIN directory.
    Possible path: C:\Program Files\Quest Software\Toad Data Modeler - Beta 3\Bin

When you run TDM 3, a new file “TDM3 log.txt” will be created in the Bin folder. There, details on the error will be stored.

Please send us the log file after starting the application.

Thank you for your co-operation!!!

Vladka & TDM Team

Latest change: Newer EXE uploaded. Message was edited by: vfrolik


#2

Hi,

Here is my log file.

I start TDM beta 3, got the nagscreen then it just close without saying anything.

I’ve uninstalled it then reinstalled, manually deleted all the trace I’ve found under :

C:\Documents and Settings\myUserid\Application Data\Quest Software

and

C:\Program Files\Quest Software

Nothing better yet, so I’ve just downloaded this binary and put the log file for analysis.

Hope this helps.

M.F.

Seems that I installed TDM a long time ago in fact.

Message was edited by: manuelflury
TDM3 log.txt (56.1 KB)


#3

I am having this same problem with the most recent beta (build 145). I have attached my error log after replacing with TDM3.exe.

Thanks, Lori Olson
TDM3 log.txt (25.1 KB)


#4

Hello all,

Please try to download the latest Beta 3.0.12.155 from:

http://modeling.inside.quest.com/ann.jspa?annID=142

Let me know if any trouble appears.

Regards,

Vladka


#5

Thanks, it is working great now. :slight_smile:


#6

Glad to hear. :slight_smile:

Thanks for letting me know.

Vladka


#7

Hello,

I’m also getting an error when starting TDM Beta 3.1.2.52. After the splash screen, a window pops up with “Cannot focus a disabled or invisible window”. After clicking on OK, I get "Access violation at address 0099BEE4 in module ‘TDM.exe’. Read of Address 00000000.

Having seen other posts regarding access violations and antivirus software, I will tell you that I’m running Trend Micro OfficeScan 8.0. My start log is attached.

Thank you,
Mark
Start TDM3 Log.txt (2.09 KB)


#8

Your message

To: john doe
Subject: Error Starting TDM 3 BETA [19ANXP-dr-40n]
Sent: Wed, 9 Jan 2008 09:08:23 -0800

did not reach the following recipient(s):

john doe on Wed, 9 Jan 2008 08:59:40 -0800
The e-mail account does not exist at the organization this message
was sent to. Check the e-mail address, or contact the recipient
directly to find out the correct address.

RESOLVER.ADR.RecipNotFound; not found


#9

Hello Mark,

Thanks for the information. We will have a look at this issue. Concerning the antivir program, TDM3 was tested with Trend Micro OfficeScan v. 8.0 and no problem was found. It ran properly.

As soon as I get some details from our developers, I’ll get back to you.

John,
If you fail to contact us, please feel free to write us to: modeling@quest.com.

Thanks.

Vladka


#10

Hello Mark,

Unfortunately, our developers haven’t managed to deal with your issue yet, snowed under with much work. So, I’m afraid, I need to ask you for patience.
Thanks very much for understanding it.

For now, you might try to do complete uninstall of the Beta version and install it again.
By the ‘complete uninstall’, I mean to delete also files from your Documents and Settings directory.
(Please back up them first, if you need them.)
Default paths are:
C:\Documents and Settings\user\Application Data\Quest Software\Toad Data Modeler Beta
and
C:\Documents and Settings\user\My Documents\Toad Data Modeler Beta

This might help.

As soon as I have some news for you, I’ll write again. Thanks for your patience.

Regards,

Vladka


#11

Hi Mark,

Here I’m with the recommendation from our developers.

  1. Please go to your Documents and Settings directory, Configs folder, Application.txc file:
    possible path is:
    C:\Documents and Settings\user\Application Data\Quest Software\Toad Data Modeler\Configs\Application.txc

  2. In this file, please find this text (e.g. using the Notepad):
    1

  3. Replace it with this text:
    0

If it does not help, please write us what configuration you selected during the install - if you made selection of databases, which of them you selected etc.

Thanks.

Regards,

Vladka + TDM Team


#12

Vladka,

While attempting to follow your instructions, I ran into these issues:

  1. My Configs folder doesn’t exist in Documents and Settings. It’s
    located at C:\Program Files\Quest Software\Toad Data Modeler - Beta
    3\Configs

  2. I couldn’t find file Application.txc anywhere in this folder or
    elsewhere.

  3. I did, however, find file Application.txd in the Configs folder, but
    I didn’t want to assume that was the file you wanted me to change, so I
    didn’t.

I’m in a SQL Server-only shop, but my initial attempt to select only SQL
Server during the install resulted in an error and a failed install.
When I selected all databases, the product installed successfully. I
was, however (after several attempts), able to re-install it today with
just SQL Server selected, but I still get the same error upon startup of
TDM.

Thank you,
Mark Heinig


#13

Vladka,

I went ahead and changed the OneInstanceOnly value to 0 in Application.txd and attempted to start TDM, but it failed as it did before.

Thank you,
Mark Heinig


#14

Hello Mark,

Here I’m with an update. (Sorry for the delay.)

My Configs folder doesn’t exist in Documents and Settings.

Have you changed the default paths during the installation process anyhow?

If not, the standard behaviour is that:

  1. TDM3 Beta is installed at:
    C:\Program Files\Quest Software\Toad Data Modeler - Beta 3

  2. As soon as you run the application (e.g. in the last step from the Install Wizard), appropriate directories are automatically created at:
    C:\Documents and Settings\user\Application Data\Quest Software\Toad Data Modeler Beta
    and
    C:\Documents and Settings\user\My Documents\Toad Data Modeler Beta

Concerning the directory Application Data, it is a hidden directory. If you can’t see it, please go to file browser menu:
Tools-> Folder Options -> View -> Show Hidden files and folders to display it.

Is it visible now?

If you uninstall the application and delete the Beta directories in your Documents and Settings, install the application again, it should work.

Next Beta will be released soon. I do believe it will work for you too.

Please let us know the result.

Regards,

Vladka


#15

Vladka,

Your uninstall/delete/install suggestion did the trick. Before reporting this problem, I had tried something similar, but I think I may have failed to delete the Toad Data Modeler Beta folder under Application Data.

Thank you,
Mark


#16

Mark, thanks for letting me know.
Glad to hear it works for you now.

In case of any troubles or questions, please do not hesitate to write.

Regards,

Vladka