Toad World® Forums

Error Toad Crashing


#1

Toad is crashing whenever I access any of my connection types. Toad software runs for about 15 seconds after connection then errors with :

Toad Encountered a serious error and must be closed.

A separate window pops up (about 10 of them with the same message) :

System.UriFormatException
Invalid URI: Invalid port specified.
Stack Trace:
at System.Uri.CreateThis(String uri, Boolean dontEscape, UriKind uriKind)
at System.Uri…ctor(String uriString)
at Quest.Toad.Util.Internet.ToadWebProxy.GetProxy(Uri destination)
at System.Net.ServicePointManager.FindServicePoint(Uri address, IWebProxy proxy, ProxyChain& chain, HttpAbortDelegate& abortDelegate, Int32& abortState)
at System.Net.HttpWebRequest.FindServicePoint(Boolean forceFind)
at System.Net.HttpWebRequest.get_ServicePoint()
at System.Net.AuthenticationState.PrepareState(HttpWebRequest httpWebRequest)
at System.Net.AuthenticationState.ClearSession(HttpWebRequest httpWebRequest)
at System.Net.HttpWebRequest.ClearAuthenticatedConnectionResources()
at System.Net.HttpWebRequest.Abort(Exception exception, Int32 abortState)
at System.Net.HttpWebRequest.AbortWrapper(Object context)
at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
at System.Threading.ThreadPoolWorkQueue.Dispatch()
at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()

I’m using Toad Data Point 3.3.0.732, running on windows 7 64 bit.

I’ve tried uninstalling and even attempted to clear appdata but I don’t think i was able to remove all traces since when i reinstalled toad it still had my connection points.

I tried to contact tech support but was told beta wasn’t supported. Can anyone assist with this issue or possibly how to do a clean install?

Thanks,
JT


#2

I dont’ recognize this error stack.
First please rename your data directory. this will reset all of your settings.
Then can you change the attached two settings and see if this makes a difference?

Debbie


#3

I dont’ recognize this error stack.
First please rename your data directory. this will reset all of your settings.
Then can you change the attached two settings and see if this makes a difference?

Debbie


#4

I renamed my local storage folder : C:\Users\justin.j.traenkensch\AppData\Local\Quest Software\Toad for Data Analysts Hub Data Old

The settings you listed were already set the way you said.

Still have same error listed earlier when i connect to DB2, SQL, or Salesforce sources after about 15 seconds of connection.

I noticed I still had all my connection settings listed, did i change the correct data folder you mentioned? I went to options->local storage->general and changed the folder name in my file structure.


#5

also noticed that toad crashed without me connecting to anything. I had the options window open and toad crashed with the same message.


#6

No that is not the data dir I was speaking of. Start TDA and open up the About box. There is a link to the data dir there. Rename that dir.

If you have win7 it will be in a similar path to this one, except it will have your profile name.

C:\Users\DPEABODY.PROD\AppData\Roaming\Quest Software\Toad Data Point 3.2

Debbie


#7

K, I renamed the data directory as well as the data directory for Beta 3.2. Reinstalled beta 3.3. After install toad loads with no data connections setup. I leave it alone (don’t connect to anything) for about 30 seconds and it crashes with the same error message as listed above.

Message was edited by: JustinTraenk


#8

This one is really weird. Disconnect your internet access. Let’s see if this stops the error. I just need some direction on where to look for the issue.

Debbie


#9

I disabled my internet connection and loaded Toad. No error occurred. Without closing Toad, I reenabled my internet connection and no error occurred. I then restarted Toad with the internet connection enabled and the error occurred again. Any suggestions as to what to try next?


#10

Can you send me your settings.xml file? I suspect that there is somekind of issue with any attempt to access the insternet on startup. The options I requested to change should have resolved that but perhaps I have missed something. Send me your file and let me have a look. This file is in your data directory.

Debbie


#11

Added.

Just as an FYI, I am on a corporate Lan and use a proxy server for internet access.

Thanks for your help.

JT
Settings.xml (39 KB)


#12

There has been a new option added for TDP 3.3. The option is to configure TDP to allow access to internet or not. Please go to your Wow6432Node area of your registry (as you menioned you have 64-bit) and add a NOINTERNET DWORD. Enter value 1 if you want to prompted each time if you want to access internet. Enter 2 if you do not want to be asked. Plesae enter 2 for now just to validate if this will handle your issue.

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Quest Software\Toad Data Point\3.3

See screenshots for example.

Debbie
AccessInternet.png


#13

There has been a new option added for TDP 3.3. The option is to configure TDP to allow access to internet or not. Please go to your Wow6432Node area of your registry (as you menioned you have 64-bit) and add a NOINTERNET DWORD. Enter value 1 if you want to prompted each time if you want to access internet. Enter 2 if you do not want to be asked. Plesae enter 2 for now just to validate if this will handle your issue.

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Quest Software\Toad Data Point\3.3

See screenshots for example.

Debbie


#14

That appears to have worked! I created the DWORD and set the value to 2. Toad has been up and running for a few minutes now without crashing. I was able to view and browse a couple database as well. I will test further on salesforce and AS400 connections and let you know if I see anyother errors. Is there any other testing you would like to do?

Thank you,

Justin


#15

I am glad this sounds like it is working. You can change the value to 1 and you will not be asked.

I wish I knew why your environment has the issue, but we don’t really have a way to track that down. So for now, let’s stick with this work around.

Debbie


#16

I’d just like to add a THANKS - I’m using the freeware version (5.8) and had the same issues and your fix has worked for me too ( obviously different location in the registry ).