Toad World® Forums

Error too harsh when trying to save to a read-only file


#1

ScreenShot182.jpeg


#2

Hi Martin,

Thanks your report. But we could not reproduce this error.

Could you pls provider more detail steps or information?

Thanks,

Michael


#3

Very simple:

Create New Text Document.txt on your Windows Desktop.

Set “Read Only” in its properties.

Open the file in sqlnav, type something, and CTRL+S.


#4

Hi Martin,

Which version are you using for Navigator now?

I think this error should display on output, not be catch by Eurekatlog.

Thanks,

Michael


#5

This is on latest 7.2.0.3807-beta_64bit

I also have installed 7.1

Exactly - the message was at the bottom in the output in previous versions.


#6

Could you have try to disable Eurekatlog option in reg?

[HKEY_CURRENT_USER\Software\Dell\SQL Navigator]

“EUREKALOG”=dword:00000000

restart Nav and try again.


#7

Hi Martin,

i can reproduce your issue with Eurekatlog option on,

we have raised defect SQLNAV-1798 for this, we will try to fixed it soon

Thanks,

Mcihael


#8

Yes, disabling the Eureka Log helps.


#9

Thanks for the confirmation Martin. We will fix this soon so I hope you wouldn’t mind to keep EurekaLog enableJ.