Toad World® Forums

Error updating data

I am a registered user of 6.1 and am also trying the 6.5 Beta. I am finding that I can’t update any data in a database named “UK-EMS-Production”. I don’t have this problem in 6.1 though. The error message I am seeing is :-

Does anyone have any idea what is happening here ? I suspect it has something to do with the “-” in the database name, but this is not a problem in version 6.1. Also, in the Beta version, I can update data in other databases.

Sorry, the image I included does not appear. The error message is saying “Database ‘[UK-EMS-Production]’ does not exist. Make sure that the name is entered correctly.”

To add to this, I have found that the problem is to do with the delimiting characters being used because of the “-” characters in the database name. If either square brackets or quoted identifiers are being used, the script generated by Toad produces a different number of delimiter characters. For example, I’ve seen something like USE [[UK-EMS-Production]]];

This is only a problem when delimiters are used. Databases with names that don’t require delimiters work fine. The error appears when I try to edit data in a grid. Sometimes, the error appears when you click the button to enable editing in the grid. Also I can confirm that this error does NOT occur in version 6.1, it is only in the Beta version.

I’ve just downloaded the new beta version 6.5.0.3159, and this problem has not been fixed. It’s a shame as I really like the new interface, but I can’t do anything with this version as it doesn’t work with my main database. Is this problem likely to be fixed ?

I have just tried the new Beta version 6.6, and this problem has still not been fixed. I can’t work with it at all. As such, have removed the Beta as it doesn’t work!!

Hi Alan,

Thanks for your feedback, I can reproduce this issue in the data grid,have create TSS-693 for it.You can use SQL Script to update data if you want to use the latest 6.6 Version.

Sorry for the inconvenience, We will fix it in the next beta.

Cathy.

Hi Cathy,

I’ve just tried the new beta release (6.6.0.291), but this bug has not been fixed.

I will continue to use 6.1.

Alan Fleet

Software Developer

Trescal Limited

Saxony Way

Blackbushe Business Park

Yateley, GU46 6GT, UK

Tel: +44 (0) 1252 533 300

Fax: +44 (0) 1252 533 333

Mobile: +44 (0) 7879 292 795

www.trescal.co.uk

www.trescal.com

Registered Office: Trescal Ltd, Saxony Way, Blackbushe Business Park, Yateley, GU46 6GT

Registered in England: Company Number: 06614164

From: Cathy.Liu [mailto:bounce-CathyLiu@toadworld.com]

Sent: 22 September 2014 10:33

To: toadssbeta@toadworld.com

Subject: RE: [Toad for SQL Server - Beta Discussion Forum] Error updating data

RE: Error updating data

Reply by Cathy.Liu

Hi Alan,

Thanks for your feedback, I can reproduce this issue in the data grid,have create TSS-693 for it.You can use SQL Script to update data if you want to use the latest 6.6 Version.

Sorry for the inconvenience, We will fix it in the next beta.

Cathy.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for SQL Server - Beta
notifications altogether.

Toad for SQL Server - Beta Discussion Forum

Flag
this post as spam/abuse.


NOTICE - This communication may contain confidential and privileged information that is for the sole use of the intended recipient. Any viewing, copying or distribution of, or reliance on this message by unintended recipients
is strictly prohibited. If you have received this message in error, please notify us immediately by replying to the message and deleting it from your computer.

This bug has still not been fixed. How do you download the older versions?

Hi menforsi,

go to this page : support.quest.com/…/download-new-releases and select release that you want download from combobox.

I hope this can help you.

Best regards,

Sergio