Toad World® Forums

ERROR Using Oracle DIRECT Connection


#1

Hello, again!

In TDA 3.0 I’m getting the following error while connecting to two (2) different Oracle 10gR2 Databases (Direct Connection):

ORA-01875: time zone minute must be between -59 and 59
This wasn’t happening before in TDA 2.7, or older versions. I started working with these Databases since TDA 2.5 and everything was OK, so far until now with TDA 3.0.

I also tried connecting to an Oracle 8i Database (despite the TOAD warning about Oracle 9i or greater support), and I’m able to work smoothly in all TDA versions since TDA 2.5 (even TDA 3.0 is working OK with Oracle 8i).

Could you guys please take a look at this?

Thanks in advance,
Oscar.


#2

Hi Oscar,

We’ll definitely take a look. Can you give us the following info:

  1. The time zone you’re in
  2. The time zone where the Oracle server is located (if different)
  3. Your regional settings (Control Panel | Regional and Language Options)

Do you have an Oracle client installed on your system as well? We’re curious as
to the choice of using Direct Connect vs. a native connection via the Oracle
client.

Alan


#3

Hi Alan!!

I’m sorry about my late response…
Extremely busy days at work :S

About the info you kindly requested:

I’m located in Caracas, Venezuela (GMT -04:30), and the Oracle Server is configured also with the same time zone (GMT -04:30). My WinXP language is set to SPANISH (VENEZUELA).

In my office we have like 7 different Oracle DB’s with different versions (8i, 9i, 10gR2, 11g). And it’s hard having to install multiple Oracle Clients for each version, and sometimes they conflict with each other, and some aren’t version-backward compatible. So, I rather use TDA (Thanks God it exists!!!) for connecting to all these DBs without having to install any Oracle Client.

I’m not sure if my way is the best one (maybe it is better to use Oracle Cient), but this is one of the features I love the most from TDA (not having to install any DB’s clients, woohoooo!!!)

Please, don’t hesitate to ask me if you need additional info.

Thanks for your concern over my post.

Best regards,
Oscar


#4

Hi, all

Any comments about this?

Thanks ind advance!
Oscar


#5

Hello Oscar,

We’re in the process of trying to reproduce the error internally. I should
have an update for you before too long. Thanks for your patience.

Alan


#6

Hello, Alan!

Any news about this? I’m still unable to connect (using TDA’s DIRECT CONNECTION) to Oracle Databases. Still getting the same error:

ORA-01875: time zone minute must be between -59 and 59

Sorry for me being so persistant about this.

Thanks in advance!

Oscar.


#7

Hello Oscar,

We’ve tried to replicate your environment changing our time zone settings
but not being able to reproduce the error. We’re also examining the code
changes we’ve made that impact timezone data but that takes a little
longer since we don’t see the issue locally. Tracing might be a little
tricky since you don’t have an Oracle client but let me see what I can
come up with. We have updated the 3rd party control we use for Direct Connect
for v3 so that’s another avenue we’re exploring as well. Thanks for
your patience.

Alan


#8

Hello, Alan

I have installed Oracle Instant Client and now I’m able to connect OK to all my Oracle DBs using TDA 3.0. But, still having the same error when switching back to Oracle Direct Connection.

Just wanted to post this small update about this issue.

Best regards,
Oscar