Toad World® Forums

ERROR Using Sybase IQ DIRECT Connection


#1

Hello all (once again)

In TDA 3.0, I’m getting the following error while trying to connect (DIRECT) to a Sybase IQ Database:

**Invalid statement
**Using ODBC and Sybase IQ Client, everything works fine, and I can connect and query the Database smoothly. The problem arises when using TOAD’s Sybase IQ DIRECT Connection.

Any help on this will be appreciated, as always.

Thanks in advance,
Oscar


#2

Hello Oscar,

Currently you get this error when trying to connect to an IQ database that is
below version 15. We have a technical support case (11645407) open with Sybase
for this exact issue. It has since been resolved and we should receive an
updated driver soon.

Thanks.


#3

Thanks for the super-fast answer!!!

As you mentioned, I’m using Sybase IQ 12.7.

Then I just have to wait for you to get the new driver and the next TDA 3.0 update that will have it. Glad to know it is just a matter of time.

Thanks!!!
Oscar


#4

No problem, I will reply to this post when the driver has been updated.

Thanks.


#5

Hi, Michael

Any news about the driver? I was testing again using the new BETA version of TDA 3.0 and still no success.

Hope you can help me out.

Thanks in advance,
Oscar


#6

Hello Oscar,

Unfortunately, we still don’t have a new driver build. I will contact Sybase and see if I can get a status update.

Thanks.


#7

Hi, Michael

Just passing by to check if you have some news about this. I tried (again in TDA 3.0.0.991) to set-up Sybase IQ direct connection to a Sybase IQ 12.7 Database, and still getting the same “Invalid command” message when trying to connect.

Hope you can get the new drivers builds.

Thanks in advance.
Oscar


#8

Hello Oscar,

We are currently testing the new driver and the fix is expected to be in the
beta following the one that will be released in the next couple of days.


#9

Thanks, Michael

Good news, then…

Would you please let me know when the Beta containing this new drivers is released?

Hope you will :slight_smile:

Thanks in advance,
Oscar


#10

Hi Michael,

Do we know if this has been fixed in Toad for Data Point 3.2 or when it will be fixed?

I am getting the error using V12.7. The release notes state that it only supports V15 as does the Beta release.


#11

Hello Mr. Toad,

The TDP 3.3 beta has the new driver and will allow you to connect to 12.7. If possible, could you please download the beta and let me know if you have any issues?

Thanks.