Toad World® Forums

Excel-Export from data grid:


#1

Hi,

Excel-Export from data grid:

  1. the “option” button is always gray and not accessible.
  2. After every export Excel stars and opens the exported file. No chance to set this off - maybe as a result from 1.

Regards
Andre


#2

Hi Andre,

  1. The Options button is enabled only for some output formats, e.g. Delimited.
  2. To enable/disable opening the exported file, there’s a checkbox on the Export form.

Hope this helps,
Roman


#3

Hi Roman,

For 2: Ah, Yes I saw/realized it now. the “open exported file”!

  1. OK too.

But while trying this I run into another pitfall.
An existing file (remembered/stored in the File browse box) is overwritten without any warning.
This way I just destroyed a earlier export file…
Can such a warning be added please?

Andre


#4

What I also find annoying is that the export dialog, when changing the format, always resets the output mode to “file” (even it it was set to “clipboard”).

This exacerbates Andre’s issue, of course.


#5

I’m not sure if what I did is different to you but I got the warning message as expected. Please see the screenshot.

To Dominique: I was able to change the setting from File to Clipboard. When I first opened the Export dialog, the option was set to File. I changed it to Clipboard and did an export. Close the dialog and reopen, the option is kept. I also closed and relaunched Nav, the option is still ‘clipboard’. Did I miss something here?
Export_data.gif


#6

Gwen,

It’s just that when you open the dialog, and it is set to export to clipboard, when you change the format (e.g. from “Table INSERTs” to “Spool Text”), it will always reset the export option to “File”.

As I mainly export to clipboard, this is (just a tad) “annoying”.


#7

Hi Gwen,

I’m sorry.
Although I was very sure, I canot reproduce this anymore.
Maybe I merely dreamed it?
I’ll keep it under observation -:slight_smile:
In the meantime forget about this please.

Thanks and Regards
Andre


#8

I got it now, Dominique. I will log a CR for this.