Toad World® Forums

Export error - out of memory


#1

The latest beta produced the out of error message below when exporting the
relatively small result set of a query on Oracle.

I used the Quick Export feature to export to a new Excel file. The data is 215k
rows, 15 columns.

I tried the exact same process in commercial 2.6 without a problem.

This transmission may contain information that is privileged, confidential,
legally privileged, and/or exempt from disclosure under applicable law. If you
are not the intended recipient, you are hereby notified that any disclosure,
copying, distribution, or use of the information contained herein (including any
reliance thereon) is STRICTLY PROHIBITED. Although this transmission and any
attachments are believed to be free of any virus or other defect that might
affect any computer system into which it is received and opened, it is the
responsibility of the recipient to ensure that it is virus free and no
responsibility is accepted by JPMorgan Chase Co., its subsidiaries and
affiliates, as applicable, for any loss or damage arising in any way from its
use. If you received this transmission in error, please immediately contact the
sender and destroy the material in its entirety, whether in electronic or hard
copy format. Thank you.

image001.png


#2

Did the Beta application have other open editors with large result sets? This
memory check is in regards to the whole application and so far I have seen it to
be accurate. So it can be an issue in exporting the 215 rows or simply that the
app space is in fact low on memory.

Can you restart the Beta TDA and run the query and see if it consistently gets
the out of mem check? And if it does I will need more info on the 15 columns,
such as data type.

Debbie


#3

I got a similar error trying to import a CSV into Oracle.
So I converted it to Excel and tried to import that way.

I usually skip the second column and the last column for this file load, but I
got this error:
Thread (71) Import Started [27/08/2010 4:07:58 PM]
Thread (71) Processing “Assignment_List.xlsx” into “STAGE.WL_ASSIGNMENTS”
Thread (71) Truncate table STAGE.WL_ASSIGNMENTS
Thread (71) Importing 1 out of 1 files
Thread (71) Reading from file Assignment_List.xlsx
Thread (71) Error importing data, please check file format options: Object
reference not set to an instance of an object.

So I inserted the second and last columns as null and imported a straight
position match but got the exact same error.

On a side note, I have an automation routine that imports csv files and it
completed successfully.

Seems I can’t import using the Wizard, but old import.tim files work correctly.