Toad World® Forums

Export to Excel instance


#1

Hi,
2 issues related to export:
a. When exporting my Excel’s instance becomes hidden [however Excel process is still active]. It’s looked like Excel [and whole export] had been crashed, but after few* seconds Excel has reappeared.

    • depending on result size. It looks like query is run again!?

b. There is a problem when exporting dates. Date 2013-04-02 15:12:20 has been exported as 413666335648148. Manual changing of filed format do not affects.

Butter


#2

Butter,

I was not able to reproduce the issues you reported. I tried beta build 1248 and export some data from Oracle920 instance to Excel instance. I have Excel 2010 installed. Could you please give us more details to reproduce the issues?

Thanks!


#3

Kiki,
I’ve put video with this case here: https://docs.google.com/file/d/0B2Hm--jqFyTUY1kwdElTV09STE0/edit?usp=sharing

in second case - I’ve exported result of this query
select sysdate a, to_char(sysdate, ‘yyyy-mm-dd hh24:mi:ss’ )b, current_timestamp c
from dual;
then attached result to this post.

Butter
export.xlsx (9.38 KB)


#4

Butter,

Thanks for the video. I was able to reproduce it now. However, this is protection machenism during writing data to the Excel file. I don’t think we can do anything with it.
On the other hand, I still cannot reproduce the second issue, I downloaded the file and tried exporting the query result to it, the date data was written fine. What buidl are you using, what Oracle server are you connecting to?


#5

Kiki,
at 1st issue - please add at least some warning. First time I used this feature I stared to search why excel crashed. Excel reappeared after ~15 sec. [it looked like whole data has been retrieved again from server]

at 2dn case: build - 3.3.0.1168, Oracle: Database 11g Enterprise Edition Release 11.2.0.3.0 - 64bit Production

Butter