Toad World® Forums

Feedback on build 825


#1

Hi guys,

Here is my feedback on the current beta build:

  1. we sometime seem to have lost the ability to run only a portion of what is in the editor. E.g. if I highlight just a portion of my SQL and click run is always tries to run the entire contents of the editor

  2. the right-arrow at the end of the line still doesn’t go to the next line

  3. when you click extract DDL or metadata you and you have no editor open currently, you get a new editor gets has two tabs (the first one is blank)

  4. while editing a stored proc, if you press Execute -> Use profiler -> Options it does n’t seem to do anything

  5. View -> “task manager” doesn’t start the task manager

  6. linking to objects still doesn’t seem to be working (i.e. CTRL-Click on an object name in the editor)

  7. with source control enabled (Perforce) and right-clicking -> “Get latest revision” on a table gives “invalid class typecast”

  8. what is the difference between Extract metadata and Extract ddl? I’ve compared the output (for a proc) and the only difference is a CR before the terminating “/” How is the output supposed to be different?

  9. the code road map seems a little flakey - sometimes I’ll go to move an object and I can’t - I can move others but the one I want seem un-selectable. Then after clicking around I’ll try again and it’s fine.

  10. I may have to refine the test case for this one, but I think what I did was

a) click browse data for a table and let it open the editor
b) In another tab, I recreated the table with a column renamed
c) forgetting that I already had a “browse data” tab open for that table I clicked on the table again and clicked “Browse Data”
The generated sql statement for the table had the OLD column name, and consequently, the query failed.

That’s all for now.

Unfortunately I’m still not able to use this release as my primary tool (using sqlnav 5.x) due to some outstanding issues that affect the way I work, but it’s getting much better :slight_smile:

DK


#2

Hi Dwayne,

Thanks again for your recent feedback. Below are our responses in order of issues you reported:

  1. Roman is working on this to get the fix to you in the next drop soon.

  2. It has been fixed and will be in the next drop.

  3. The empty tab will be removed in the next drop.

  4. Nice catch :-). This is a known issue, on Roman’s list to do.

  5. I suspect that the dockable windows layout has been corrupted, could you please try to delete the registry entry: HKEY_CURRENT_USER\Software\Quest Software\SQL Navigator 6.0.0 Beta\Docking Windows.

We have received a number of cases where the dockable window layout corruption occured. The only work around now is to remove the registry. We did not have any success yet to detect/stop the corruption yet…

  1. It has been reported earlier.

  2. It will be investigated.

  3. Extract DDL scripts generated internally by our code, where it provides more complete object denifition regarding dependencies…

Meta data is generated using SYS.DBMS_METADATA. Its performance is better than extractddl but not as complete as ExttractDDL scripts. Some of the objects scripts might be the same for both extracts.

  1. I could not reproduce this issue yet. Will have Sekhar/Roman to check it out.

  2. It will be investigated.

Thanks and regards,
Bruce


#3

Regarding issue #5, removing the registry key did not seem to resolve the issue.

Not a big deal for me since I don’t use this feature much, but I thought you should know.


#4

Hi,
I can’t start task manager too…


#5

Hi Dwayne & Piter,

Just want to clarify that when you click View->Task Manager, you could not see the Task Manager window? or you can see the Task Window but it is empty?

Thanks,
Bruce


#6

Hi,
I can’t see Task Manager window.
clip0005.zip (329 KB)


#7

In my case I don’t see anything change (i.e. no new window pops up)

DK


#8

We’ve still had no luck on replicating this…

Piter, did the window come back when you deleted the registry key??

DK, What happens when you ‘Reset Docking’ via the View menu (see attached image).

I can make the window disappear by severe fiddling, or by setting it to auto hide and then popping it up. BUT I can get it back (easily) via the ‘Reset Docking’ option.

  • Jaime -
    reset_docking.jpeg

#9

Hi Jaime,
After reseting registry keys, window comes back :wink:


#10

Sorry - resetting the docking didn’t seem to fix it either.

One thing I did notice though is that when I actually click on the “Task Manager” item in the menu, the window loses focus. Almost like the window is getting created somewhere (I’ve checked behind all my windows)

DK


#11

This is very perplexing DK.

But it just occurred to me, that perhaps you are not closing SQL Navigator before you delete the registry key.
The key is written to when Nav is closed…
…so if you have Nav open when you delete the key, it is re-writing the corrupt data to the key on application close.

So, ensure that SQL Nav is closed… delete the key… re-launch SQL Nav:
The key should then be recreated with the window in the default position.

Can you please confirm that you have followed this workflow?

  • Jaime -

#12

Had a chance to check this out yet DK ??

  • Jaime -

#13

Just tried this morning. Seems fine now. Not sure what I did wrong the first time.

Thanks for checking in