Toad World® Forums

Find /Replace modal problem


#1

Hi

Maybe this was already reported

Having a package body opened ->Open Find Replace and then make several finds (or replaces) if that “modal” window is in the center when the window “reached the end of file …” appears you will not see that other window (it will be below the find/replace window :-)) and it would appears that the system is hanged

workaround: make sure the find/replace window is not in the center.

Regards
Filipe


#2

This problem is also ocuring with the “teamcoding checking all window”
for instance a save window will appear in the back (as the window for check out commentaries)


#3

Filipe,

We used to have this issue but could no longer reproduce in our environment. Are there certain steps that make this appears more often?

Gwen


#4

Hi Gwen

If I do any of those two workflow actions I mention above I got that everytime

for the second scenario:
Having checked out several packages I edit one (didn’t save)
select Team coding->check in all …try to select all and press ok


#5

I still cannot reproduce the issue. Do you have dual monitor setup. If so what is the resolution and which one is your main screen?

Gwen


#6

Gwen,

I could reproduce it quite easily:

  1. open a package (cursor should be at the top left)
  2. do CTRL-H, select “backward” direction, enter a “text to find” and “replace with” (e.g. both “PACKAGE”) and click “Replace All” (nothing will get replaced, of course)
  3. click “Cancel”
  4. redo 2)
  5. click “Find” - the “Confirmation - Reached top of file…” dialog will be “under” the “Find and Replace” dialog.

Then again, I do have a dual-monitor setup, both at 1920x1200.


#7

My screen resolution is 1680*1050


#8

With build 1749 I didn’t get the find/replace modal problem I reported


#9

*> With build 1749 I didn’t get the find/replace

modal problem I reported

But I did:

  1. Start SqlNav, connect to schema SYS

  2. open package body DBMS_ADVANCED_REWRITE, do CTRL-H, (the text to find should be PACKAGE, the first word in the code - otherwise, just enter PACKAGE). Select “Backward” Direction, click “Find”.

  3. Click “No” in the “Confirmation” dialog asking if one should search from the bottom. Click “Cancel” in the “Find and Replace” dialog.

Redo 1) : “Confirmation” dialog will be “under” the “Find and Replace” dialog.

Arbitrarily reproducing this problem was not easy, in several other of our own schema’s, the problem did not appear, or only after opening several package bodies and/or searching more than 2 times. The above described flow “works” at our database (10.2.0.4 64-bit), however.


#10

We haven’t made any changes yet as the issue could only be reproduced in one machine at our site. We will continue our investigation and keep you guys up to date.

Gwen


#11

Hi

I also get the “teamcoding checking all window” modal problem with 1749


#12

I also can reproduce the Find /Replace modal problem

My resolution is 1680*1050 (I tried with and without dual monitor)


#13

Hi All,

We have made progress and made changes in this area to make sure the confirmation window will be always ontop. The fix will be in the next beta build which will be available for you sometimes next week.

Thanks and regards,
Bruce


#14

Hi

With Build 1828 the problem happens again!

(I hope you can fix it for 6.3 final)

regards
Filipe

PS: I mean ->Find in a package using the modal find window’s find button until the message “reached end of file” appears…it will be below the find window

Message was edited by: Fsilva


#15

Hi Filipe

I previuously was able to reproduce the issue, but am not able to in the latest beta.
Is there more information you can give me, or is there something specific about what you are trying to do?

At this stage, I doubt we will be making any more changes for 6.3 but would like to work with you to reproduce the issue so we can fix it properly for the next version.

regards
Lidia


#16

Hi

I think that in previous beta it was fixed.

Open a package. Put the cursor somewhere in the middle.
open the find panel
look for something that it not find -> from cursor -> use the button find

The message window was below the find window

I said was because today I was not able to reproduce the error (I made restart of SQL Nav meanwhile)


#17

Hi again

I have again the problem …I have SQLNav already open for some hours
Maybe is after some lost connection ?

I will try to figure out a way to reproduce the problem

Regards


#18

Hi Filipe

I tried to lose a connection and have had SQLNav running for about 24 hrs, I still cant reproduce.

Eagerly awaiting your steps to reproduce.

thanks
Lidia


#19

It happens still with build 1920 (and I didn’t lost connection) the reported problems with the confirmation window (to go back to the start of the package) appears below the find/replace window.

I have Team coding ON with automatic check in , automatic check out, simultaneous check in/out of packages, disabel login prompt… and disable upgrade prompt … ON