Toad World® Forums

Fit to Page Makes Text Too Small

I find that when I print with “fit to page” that text gets too small. I would like to be able to use some multiplier that would increase the assigned font size everywhere. I can set this multiplier after an initial print, re-adjust the layout as needed. That should get me close to want is readable for most people. Now I have to go back and change all the font size settings.

Thanks for your consideration,
Dave Reed

Dave,

you can modify paper format first: click File | Page format, select your printer at bottom of the dialog and then specify your paper size. Next, enable option Visible Page Boundaries in Options. Click Settings | Options and in section Graphics, enable check box Visible Page Boundaries. You will see printable area then. As a final step, change layout of your entities to state when all your objects are inside one paper. This way you will nicely see what will be printed and what will not be printed and you will also be able to keep font in one defined value - and you will not have to change it everytime.

BTW: font settings can be specified for new models in Options in section Model | Physical model on tab Workspace.

Another tip: To change autolayout you may try to lower values in Options in section Graphics in groupbox Autolayout.

Regards,

Vaclav

I (and others) have related issues with font setting and Entity Width (at least in Physical Model):

There are at least three Font settings:

(1) Menu: Settings >> Options >> Model - Physical Model >> Workspace >> Font Settings

(2) Menu: Settings >> Options >> General >> Font Settings

(3) Menu: Settings >> Options >> Model - Logical Model >> General>> Font Settings

  1. Neither of the first two above Font Settings has any effect on the font used in the graphical display of the Physical ERD, thus it doesn’t help to choose a narrower font to make Entities not so wide. Is this intentional? Is the fact that they have no effect on Entity display a bug? To get the desired effect, is it necessary to make the Font Setting in a New (empty) Model, then start creating Entities etc.? If yes, this is no help after one realizes his/her ERD no longer fits on one page (usually very desirable).

  2. I agree that the option to choose which columns are shown on Attributes would be a better solution to the “Excessive Entity Width” problem; please advise the best way to request this feature.

Thanks.

Jim Harris

Hi Jim

most of the general settings in Settings | Options becomes active, when changed, for a new model. To change font settings for your current model, right-click the particular entity, select Format | General | Font Settings and pick a desired font. Or if you want to change the font for all the workspace, right-click the particular workspace and select Workspace Format | General | Font Settings and pick a desired font.
You can also change Display Level, which has quite a big influence on the size of entities.

Regards,
Lukas