Toad World® Forums

FTP Step Failure - Automated Tasks

Good morning! I have a weird issue that started a while back and we only just noticed it. I have a daily script that FTP's a file to a vendor. It's stopped sending the file. It worked flawlessly every day for a year and then dropped off about a month ago. The file is on the disk and I don't think anything has changed. When I try to run the task manually, I go to the FTP step and all I get is: "Failed execution: Unable to connect: (site name)". What's weird is that if I go to Utilities and FTP and open the same site - it goes right in - and I can upload the file manually - no problem.
Settings between the step and the manual mode look the same - in fact, I'm fairly sure that Toad keeps all FTP info in one place, so there shouldn't be two connections, etc. I had my Toad partner at work review the job and she can't see anything wrong either - it's very strange. Any ideas and maybe how we can better troubleshoot? I tried exporting the task and importing it on a different machine - same results. The FTP line will not connect and send the file.

I haven't run into this issue personally, but if no one else has either, may I suggest reaching out to our Support team for this? They can document this issue formally, try to reproduce, and collaborate with our Dev team for a fix.

Thank you. If it doesn't jump out at anyone else, I'll plan to do that.

Another recommendation I'd have is to contact the admin for the FTP server to see if anything has changed recently, patches, settings, etc. if nothing that you're aware of has changed. What version of Toad for Oracle are you using?