Toad World® Forums

FW: Toad-SS Beta failure in swithing between two editor files


#1

Toad-beta release faults and crashes the application when switching between two
editor files.

I was unable to obtain a support bundle because the application crashed….

Hank Freeman

Senior Systems, Database/Data Warehouse Architect

hfreeman@msn.com

678-414-0090 my cell Primary

image001.gif

image003.jpeg

image004.jpeg


#2

Hi Hank,

Looks very weird. L

This is related to Out of Memory issue in Editor, that we are working on now. I
saw this couple of times on my side and it was b/c of large load in Toad before
or during getting this red crosses.

Can you please send me your ExceptionTrace.log file for the investigation? I
suppose you know where to get it.

regards,

Alexander Maximov
image002.png


#3

Hi Hank,

Looks very weird. L

This is related to Out of Memory issue in Editor, that we are working on now. I
saw this couple of times on my side and it was b/c of large load in Toad before
or during getting this red crosses.

Can you please send me your ExceptionTrace.log file for the investigation? I
suppose you know where to get it.

regards,

Alexander Maximov
image002.jpeg


#4

Hi Hank,

Looks very weird. L

This is related to Out of Memory issue in Editor, that we are working on now. I
saw this couple of times on my side and it was b/c of large load in Toad before
or during getting this red crosses.

Can you please send me your ExceptionTrace.log file for the investigation? I
suppose you know where to get it.

regards,

Alexander Maximov
image003.jpeg


#5

Hi Hank,

Looks very weird. L

This is related to Out of Memory issue in Editor, that we are working on now. I
saw this couple of times on my side and it was b/c of large load in Toad before
or during getting this red crosses.

Can you please send me your ExceptionTrace.log file for the investigation? I
suppose you know where to get it.

regards,

Alexander Maximov
image001.gif


#6

BTW,

Can you please remember about your activity at this particular time
image002.png


#7

BTW,

Can you please remember about your activity at this particular time
image002.jpeg


#8

BTW,

Can you please remember about your activity at this particular time
image001.gif


#9

BTW,

Can you please remember about your activity at this particular time
image003.jpeg


#10

Can you please remember about your activity at this particular time

  • Did you have any active queries in any of the editors windows?

@HankF à no there were no active queries, I had just installed the application
and was changing a know good script to restore a database to another DBName

  • Are these editors for one server connection or for different?

@HankF- à usually I am connected to one at a time because the database names
between, dev, test, release and production server are all the same so this way I
make sure I am address the correct database on the correct server, which was the
case on the error, because I was performing a restore.

  • did you have any other suspicious errors on this Toad session?

@HankF à No, the only other things going on was Outlook and IE and a few
Windows Explorer sessions.

@Hankf à It seems to me is all I have to do is something simple in Toad-SS
like just type or edit and it take a dump in its shorts and doesn’t know
why or what to do… Today on this beta it became completely DRT (Dead Right
There) and I had to flush the application with task manager and start over.

Hank Freeman

Senior Systems, Database/Data Warehouse Architect

hfreeman@msn.com

678-414-0090 my cell Primary
image001.gif


#11

Can you please remember about your activity at this particular time

  • Did you have any active queries in any of the editors windows?

@HankF à no there were no active queries, I had just installed the application
and was changing a know good script to restore a database to another DBName

  • Are these editors for one server connection or for different?

@HankF- à usually I am connected to one at a time because the database names
between, dev, test, release and production server are all the same so this way I
make sure I am address the correct database on the correct server, which was the
case on the error, because I was performing a restore.

  • did you have any other suspicious errors on this Toad session?

@HankF à No, the only other things going on was Outlook and IE and a few
Windows Explorer sessions.

@Hankf à It seems to me is all I have to do is something simple in Toad-SS
like just type or edit and it take a dump in its shorts and doesn’t know
why or what to do… Today on this beta it became completely DRT (Dead Right
There) and I had to flush the application with task manager and start over.

Hank Freeman

Senior Systems, Database/Data Warehouse Architect

hfreeman@msn.com

678-414-0090 my cell Primary
image002.jpeg


#12

Can you please remember about your activity at this particular time

  • Did you have any active queries in any of the editors windows?

@HankF à no there were no active queries, I had just installed the application
and was changing a know good script to restore a database to another DBName

  • Are these editors for one server connection or for different?

@HankF- à usually I am connected to one at a time because the database names
between, dev, test, release and production server are all the same so this way I
make sure I am address the correct database on the correct server, which was the
case on the error, because I was performing a restore.

  • did you have any other suspicious errors on this Toad session?

@HankF à No, the only other things going on was Outlook and IE and a few
Windows Explorer sessions.

@Hankf à It seems to me is all I have to do is something simple in Toad-SS
like just type or edit and it take a dump in its shorts and doesn’t know
why or what to do… Today on this beta it became completely DRT (Dead Right
There) and I had to flush the application with task manager and start over.

Hank Freeman

Senior Systems, Database/Data Warehouse Architect

hfreeman@msn.com

678-414-0090 my cell Primary
image002.png


#13

Can you please remember about your activity at this particular time

  • Did you have any active queries in any of the editors windows?

@HankF à no there were no active queries, I had just installed the application
and was changing a know good script to restore a database to another DBName

  • Are these editors for one server connection or for different?

@HankF- à usually I am connected to one at a time because the database names
between, dev, test, release and production server are all the same so this way I
make sure I am address the correct database on the correct server, which was the
case on the error, because I was performing a restore.

  • did you have any other suspicious errors on this Toad session?

@HankF à No, the only other things going on was Outlook and IE and a few
Windows Explorer sessions.

@Hankf à It seems to me is all I have to do is something simple in Toad-SS
like just type or edit and it take a dump in its shorts and doesn’t know
why or what to do… Today on this beta it became completely DRT (Dead Right
There) and I had to flush the application with task manager and start over.

Hank Freeman

Senior Systems, Database/Data Warehouse Architect

hfreeman@msn.com

678-414-0090 my cell Primary
image003.jpeg


#14

Hank,

I’m trying to reproduce this but it seems to me that you have some magic
laptop J

I’ll try to order absolutely the same laptop as you have for me to test OR
another one with the same parameters but not Toshiba for you - so you can
present it to me, use a new one and will not have such issues J

Honestly, issue below indicate that toad has memory issues L All the time it
doesn’t depend on scripts, connections etc. but on activity and load. It
is hard to believe for me that you had this right away after toad start…

regards,

Alexander Maximov
image003.jpeg


#15

Hank,

I’m trying to reproduce this but it seems to me that you have some magic
laptop J

I’ll try to order absolutely the same laptop as you have for me to test OR
another one with the same parameters but not Toshiba for you - so you can
present it to me, use a new one and will not have such issues J

Honestly, issue below indicate that toad has memory issues L All the time it
doesn’t depend on scripts, connections etc. but on activity and load. It
is hard to believe for me that you had this right away after toad start…

regards,

Alexander Maximov
image002.png


#16

Hank,

I’m trying to reproduce this but it seems to me that you have some magic
laptop J

I’ll try to order absolutely the same laptop as you have for me to test OR
another one with the same parameters but not Toshiba for you - so you can
present it to me, use a new one and will not have such issues J

Honestly, issue below indicate that toad has memory issues L All the time it
doesn’t depend on scripts, connections etc. but on activity and load. It
is hard to believe for me that you had this right away after toad start…

regards,

Alexander Maximov
image002.jpeg


#17

Hank,

I’m trying to reproduce this but it seems to me that you have some magic
laptop J

I’ll try to order absolutely the same laptop as you have for me to test OR
another one with the same parameters but not Toshiba for you - so you can
present it to me, use a new one and will not have such issues J

Honestly, issue below indicate that toad has memory issues L All the time it
doesn’t depend on scripts, connections etc. but on activity and load. It
is hard to believe for me that you had this right away after toad start…

regards,

Alexander Maximov
image001.gif


#18

Alex this issue on a Window XP system with 4gb of memory… This is where
the problem exists… my Dell workstation.

The issue started with 10 minutes of starting the new beta system….

Funny thing about Toad-SS, it work quite reliably if you TURN OFF à CODE
Complete… Imagine that !!!

If you want to order a laptop like mine it is a Toshiba BestBuy blue label
E205-S1904 system with all the bells and whistles…

Hank Freeman

Senior Systems, Database/Data Warehouse Architect

hfreeman@msn.com

678-414-0090 my cell Primary
image002.png


#19

Alex this issue on a Window XP system with 4gb of memory… This is where
the problem exists… my Dell workstation.

The issue started with 10 minutes of starting the new beta system….

Funny thing about Toad-SS, it work quite reliably if you TURN OFF à CODE
Complete… Imagine that !!!

If you want to order a laptop like mine it is a Toshiba BestBuy blue label
E205-S1904 system with all the bells and whistles…

Hank Freeman

Senior Systems, Database/Data Warehouse Architect

hfreeman@msn.com

678-414-0090 my cell Primary
image002.jpeg


#20

Alex this issue on a Window XP system with 4gb of memory… This is where
the problem exists… my Dell workstation.

The issue started with 10 minutes of starting the new beta system….

Funny thing about Toad-SS, it work quite reliably if you TURN OFF à CODE
Complete… Imagine that !!!

If you want to order a laptop like mine it is a Toshiba BestBuy blue label
E205-S1904 system with all the bells and whistles…

Hank Freeman

Senior Systems, Database/Data Warehouse Architect

hfreeman@msn.com

678-414-0090 my cell Primary
image001.gif