Toad World® Forums

Generating DDL for a package


#1

Ok, I click on a package body and do a ctrl-D and what is generated has a bunch of control characters in it.

It appears to run, but it’s pretty ugly.

BTW, I like the colors and fonts for the toolbox. :slight_smile:

Jet


#2

Hi Jet,

I couldn’t reproduce the error but I believe I get the same bug if I drag something from the COde Assisstant window. It used to happen when I performed get metadata as well but as of this morning, get metadata is working fine. Anyway, I couldn’t reproduce any of these in ROman’s machine. We will investigate more and see what we can do. For now, if you save it to a file and open it again, I believe these annoying things will disapppear. Copy and paste them in another editor will also do the trick. I know it’s tacky but that’s the only solution i can come up at the moment.

HOpe this helps!

Gwen


#3

Yeah, after I posted this, I tried it again and it worked fine. There must be some kind of combination of events that causes it.

I’ll keep an eye out and see if I can duplicate it.

Jet