Toad World® Forums

global index job canceled due to memory limitation


#1

Hi ALL,

i got error during global indexing job.

i setup sql repository using sql scanner & inspector
and there are about 1500sqls in the sql repository.

i send all the sqls to global indexing from sql repository.
during global indexing job, i get error messages as below

** ERROR:Available Memory is low, Now cancelling command.

i have 2Gbytes Memory in my test system
and i also set memory thresholds to 100% in SQL Optimizer options.

So, i think SQL Optimizer has to suppot one of this options.

  1. find queries for a specific table (filter option), and send to global indexing
    just this filted queries.

  2. install sql optimizer agents on serveral systems and using parallel optimization or global indexing job (just like Benchmark factory ^^)

Thanks,
woong


#2

Thanks for the suggestion. It is really great for us to put your idea into our ehnacement list, especially the first point. A filter for respository SQL or even scanner SQL could be helpful to minimize the wastage of resource.

Thanks again,

Tony Ng