Toad World® Forums

how can I eliminate and update entries in the connection manager ?

We have moved our databases to new servers and all of the connections that were previously created in the connection manager were still listed. I had to create new ones for the new databases. I selected the old ones and right-clicking chose to remove from list. I had about 50 diferent connections setup for the old database. After I removed them, I was only left with my valid connections in the list. But when I closed SQL Optimizer and reopen it, all of the invalid connections are back in the list. How do I get rid of the invalid connections permanently. Also because of PCI compliance, our passwords change every 90 days. But I don’t see an easy way to just update an existing listed connection.

Please note that SQL Optimizer for Oracle will copy the connection setup in TOAD automatically everytime it launch. So to verify the invalid connection are really copied from TOAD, please remove all of the connection in QSOO first, then remove some of the invalid connections in TOAD. Then see if these invaild connections still show in QSOO after launched.

Thanks

I documented the steps I took.

I first went to TOAD and I eliminated all of the old unwanted connection
settings, about 30 of them.
I show have 7 connection settings remaining.

I then closed TOAD and opened SQL Optimizer connections window and
deleted ALL of the connection settings.
I show the the connection window connections blank.

I exit SQL Optimizer and reopen TOAD and check my connections, still
only 7 available.

I then reopen SQL Optimzer and the connections window.
I still show at least 30 connections.

There must be some other backup connections file that SQL Optimizer is
using as it’s reference.

Rich Stucke DBA
Meridian Enterprises
richs@meridinet.com
314-592-3199
“The essence of knowledge is how to apply it.”
SQLOptimizer_BUG.docx (125 KB)

SQL Optimizer will look for the CONNECTIONS.INI under the “C:\Documents and Settings<user name>\Application Data\Quest Software\Toad for Oracle” folder and its sub-folder(s). So, I suggest temporary rename each occurrence of the CONNECTIONS.INI (say _CONNECTIONS.INI) found and remove all of the connections in SQL Optimizer. Then, reopen QSOO to see if this work.

Thanks

I renamed ALL connections.ini files that I could find on my pc, and when i go back in to SQL Optimizer and select the connections tab, I still get all of the unwanted connections. I’m thinking it’s not the connections.ini that it is looking at. It may be referencing against the connections.ini, but it’s not one directly.

Your problem need further investigation. Please open a case with our technical support. So that I can send you a debug build to identify the problem.

Thank you very much.

Kelvin

I figured out what is going on, and I think it is a bug or a design
flaw.

  1. I had multiple CONNECTIONS.ini files because older version
    components were still in the ApplicationData\QuestSoftware\Toad for
    Oracle\ folders. As requested I renamed them.

  2. I still had the problem, but thinking that even though the files
    were renamed.they still had the old connections in them. So I deleted
    all but the current one and deleted all the old unwanted connection
    entries in the file.

I rebooted my pc and just opened SQL Optimizer, I still had all the old
as well as the new connections listed. I suspected another file is
actually referenced in the connections window. I found it. In the
ApplicationData\QuestSoftware\SqlOptimizer for Oracle\8.0.0\ folder a
file CONNPOOL.ini and all of the connections listed in the window were
in there. Problem solved. I deleted all entries in this file. I
closed the Optimizer and reopened the optimizer. Only my new
connections showed up. I thought I was finished, until I had to open a
new user connection in TOAD. It was only going to be a one-time
connection, but while in TOAD I also opened the Optimizer, and that
one-time connection showed up. So in TOAD I deleted that connection
reference and then reopened the Optimizer and my one-time connection was
there. I checked the CONNPOOL.ini and It was in there. I deleted the
one-time connection from that file. Reopened Optimizer and it was gone.
So the Optimizer will ADD new connection entries from the TOAD
CONNECTIONS.ini into the CONNPOOL.ini but it doesn’t DROP connection
entries in the CONNPOOL.ini that are no longer in the TOAD
CONNECTIONS.ini. ( Is this a bug or is it designed to behave this way ?
).

Rich Stucke DBA
Meridian Enterprises
richs@meridinet.com
314-592-3199
“The essence of knowledge is how to apply it.”