Toad World® Forums

Import/Export


#1

Background:
Our current configuration has the CodeTester repository in a schema called CODETESTER and our Test Definitions in a schema called CIS_TESTER. All code application functions, procedures and packages are in a schema called CIS.

A Test Suite was accidentally created in the CIS schema (which owns the packages we need to test). I need to move the Test Definition to the CIS_TESTER where it belongs.

I’ve tried export and import but I’m possibly using either the wrong export or import options as the Test Definition isn’t importing from CIS to CIS_TESTER successfully.

Can this be accomplished (moving a Test Definition to another schema) and what are the correct steps to do this?


#2

Sorry about the delay in answering. The watch on this forum expired. Silly software!

Probably the simplest way to address this is to edit the export file. Open the file and replace CIS to CIS_TESTER and that should do the trick.

SF


#3

Thanks for the feedback…

I tried that to no avail. I keep getting the following message after I attempt the import. I’ve checked all the privileges (assuming this is what it is) but I keep getting this. Maybe I’ve overlooked something.

“The import for CIS_TESTER.SEP_STATUS_PKG was completed, but Code Tester was not able to verify the existence of that program. The test definition will not, in this case, appear in the Test Definition browser. This may be due to role-based execution privileges on the program.”


#4

Ah…the SEP_STATUS_PKG is actually owned by CIS, correct? And you execute it/test it from CIS_TESTER?

Then (my apologies) the program owner for this test definition should be set to CIS. You should be able to set it to that in the import window in the Tested Program Owner section.

If this does not seem to be doing the trick, then go back to the export file, search for

program_owner_in

and change it to CIS.

Regards, SF