Toad World® Forums

Increasing decimal points in AVG summary


#1

Hello,
I have attached a screen shot of the query.
In the group panel I have average values.
I wonder if there is a way to increase a number of decimal points to 3 instead of 2.
Thanks,
Chris

img.jpeg


#2

Right now we do not have an option for the precision value. I have entered CR72,046 for your request.

Can I ask, are the average values something you do on the fly? Or are they something you would like to be kept in the saved Query Builder or Toad Editor File?

Debbie


#3

Hi Debbie,

Actually, I built a query in SQL, did not use query builder.
Data change on the fly, so I do not need to keep it saved.

Is there a way to export this format into the Excel saving averages ?

Also, If I could ask, do you have any plans to support Postgres. I tried to use ODBC and did not work for me.

Regards,
Chris


#4

Currently we do not offer to send the column functions to Excel. I think that is an interesting enhancement and have entered that as CR72,088.

Regarding, Postgres, this should work. Can you post specifics of what issues you are having and what driver version you are using with ODBC?

Debbie


#5

In my ODBC I do not have any Postgres drivers, although I have 8.4 installed locally.
I have added two screen shots of my ODBC.
Mostly MS drivers and Oracle.
Could you advise how I can add a driver for Postgres to it?

The reason I asked about Postgres is that I love multi-platform database synchronization.
Ability to synchronize between Oracle and Postgres is my wish.
sc2.jpeg


#6

In my ODBC I do not have any Postgres drivers, although I have 8.4 installed locally.
I have added two screen shots of my ODBC.
Mostly MS drivers and Oracle.
Could you advise how I can add a driver for Postgres to it?

The reason I asked about Postgres is that I love multi-platform database synchronization.
Ability to synchronize between Oracle and Postgres is my wish.
sc1.jpeg


#7

You can grab the latest Postgres ODBC driver from here: http://www.postgresql.org/ftp/odbc/versions/msi/

Please let me know if you have any issues.

Thanks.


#8

Hi Michael,
Thanks for the link.
I installed the driver and worked.
I was able to query.

I tried to do synchronization (do not know if this is supported in TDA) but got the error.
See the screen shot.
It refers to ‘TABLE_CAT’ somewhere in the schema but I do not see it.
Any thoughts on it are appreciated.
Thanks,
pgSynchro.jpeg


#9

No problem, sorry to hear you have an issue with data compare. I went ahead and created CR Number 72,163 for this issue.

Thanks.


#10

Hello Greener,
Issue in Data Compare was confirmed, CR71,163 was fixed and will be available in the 3.0 release. Thanks for the help.

regards,
Alexander