Toad World® Forums

Internal Error


Trying to reverse engineer oracle database to create ERD got the following error. Please see attached screenshot.

SOURCE: cs3 - Internal Error
Script: RE Oracle 10g
Description: [Oracle][ODBC]Invalid descriptor index <4>
Row: 304
Column 5


toadmodelererror.doc (123 KB)



Please try to use ADO, the “Microsoft OLE DB Provider for Oracle” provider.
Please let us know the result. Thanks in advance!




The first time I clicked the Finish button with some tables selected as shown in the screen shot in figure 1 and got an “unspecified error”
the second time I tried I with no tables selected and clicked the Finish button and got “Operation is not allowed when object is open” as shown in figure 2.
toadmodelererror1.doc (218 KB)


Please ignore my earlier post. Here is the error I am getting now after making the change “Microsoft OLE DB Provider for Oracle” using ADO. I did a test connection with the ADO and get the following error message -
“Test connection failed because of error initializing provider. ORA-12154. TNS:could not resolve service name.”
Details in attached screenshot.
toadmodelererror2.doc (108 KB)


myORACLE10 =
(ADDRESS = (PROTOCOL = TCP)(HOST = mario)(PORT = 1521))
(SERVICE_NAME = oracle10)

the net service name would be myORACLE10.

Partho, if you encounter another trouble, please write us back. Thanks.


Vladka & TDM Team

Hello Partho,

To set up the provider properly, you need to define a correct Net Service Name in the “Enter a Server Name” text box. - Please see the Data Link Properties dialog | Connection tab.

If you don’t know the net service name, you can find it in Oracle TNSNAMES.ORA file.

If the following would be here:


I connected using the MS ADOand the only tables showing up are for the schema for my user name. I need to be able to see all the tables for all of the schemas.

The tables tab shows only my schema and it is greyed out so I can not see any more.

I can connect with Toad and see all of the schemas, but can not with the modeling tool.



Please select the ‘Load All Accessible Objects “ALL_”’ checkbox in the Options step in the RE Wizard.


Vladka & TDM Team