Toad World® Forums

Job Scheduler disable


I am unable to disable a Job by unchecking the Enabled box. Is that how you are supposed to temporarily disable a job?



you can check/uncheck checkbox in list window, first col is enabled/disabled option

Regards Piter


Hi Charlie,

That is right. You can use the check box to disable job. It is working here for me…

Can you try to select the job in the list view then uncheck the box and see if it would work for you?



I’m not sure what is wrong with my setup. I can’t check or uncheck that box. It is like it is disabled, but it doesn’t look disabled. The box gets a yellow border when I hover with my mouse, but nothing happens when I click.



Hey Charlie,

I was having a look at this with Bruce this morning, and we did find a couple of issues:

  1. Sometimes when un-checking the (or checking) the checkbox, it can take SQL Nav a while to update your selection. So much so, that you may have repeatedly clicked on the check-box. We need to turn the cursor to an hourglass, so that the user knows that something is happening.

  2. If an error is generated when you Uncheck (or check) the checkbox… the error message is being thrown to the background. When this happens, SQL Nav appears to be unresponsive. We need to cancel the display of the error dialogue, and just have the error message sent to the output window.
    (If you hit to cycle back to the SQL Nav app, the message would appear.)

Can you check and see if either of these are causing your issue?
I’m going to log a CR for these. If this is related to your issue, I’ll add your ID to the CR.



The answer is simple. This problem, like many others you have, exists only when Oracle version is below 10. You can’t enable/disable jobs in dbms_job, only in dbms_schedule. I don’t believe I can recommend that you upgrade your Oracle server (unfortunately), but you should be aware that Job Scheduler was initially designed for 10g, and then we added some support for earlier versions - with all the limitations that those versions imply.


PS The problem Jaime is talking about has nothing to do with it.

Message was edited by: roman


So it would appear the issues that Bruce and I found are not related to Charlie’s problem.