Toad World® Forums

Job Scheduler


#1
  1. In the Jobs view, you can’t expand the Interval/schedule column to see it all.

  2. In the Next Date (below the Jobs list after you create a job), in the Time field, if you click on a time piece (hour, minute, or seconds, then click the up or down arrow, your item loses focus. You can only increment it one at a time. It looks like the focus goes over to the checkbox. This works fine when you go through the Wizard to initially set it up.

  3. For the Repeat Interval, is it possible to pop up a dialog box like there is in the Wizard? After you create a job, you may not have an interval to begin with. Then you might want to come back later and add one.

Thanks.
-Charlie


#2

Hi Charlie,

Job Scheduler is Roman’s baby .

Roman will look into this for you and will get back to you next week.

Thanks,
Bruce


#3

Hi Charlie,

Here’s my initial response to your feedback. I’ll keep thinking and will come back to you later with more.

  1. Right. I thought this functionality (expand columns on double click) is the default behavior of the component, but in fact there is an option to switch it on. Will be fixed in the next iteration.

  2. I am aware of this problem. I don’t know why the time edit component behaves this way and will have to look again.

  3. For Oracle 10g, there is a Calendar button which displays a “calendar” where you can not only choose various intervals, but also set irregular intervals like every Monday and Wednesday, etc. I think we can add a similar dialog for earlier versions of Oracle, much simplified of course.

Roman


#4
  1. Just to clarify, I am able to drag all the other columns larger except the last one. It also looks like there is an empty column at the end. There are two column handles on the right side of the Interval/Schedule column.

It also seems that double-clicking on the column handle sorts the right-hand column.

Thanks.
-Charlie