Toad World® Forums

Knowledge Expert Engine


#1

Hello,

I’ve noticed quite a few times that after a while using SQLNav, there appears a little square thingy in the top left corner of my desktop (Windows XP Professional 64-bit, BTW) - see first screenshot.
It’s an actual window, that can be expanded by clicking and dragging the lower right corner (not much to click on, practice your aim!) - see second screenshot.
This window seem to belong to the “Knowledge Expert Engine” (that’s what Process Exporer tells me anyway), but closing it does not seem to stop this or any other process.

I think (but am not sure) that this window appears after double-clicking on an Oracle error message in the output window (to bring up the Oracle Error Information dialog).

SQLnav6_B20_1.png

SQLnav6_B20_2.png


#2

This is quite strange. I tried double-clicking on the error message and only the Oracle error information popped open. It always stays on top of NAV unless you use alt+tab to switch to another application. Even then, the window will appears unabled and if you click on anything, it will go back to nav. It’s definitely not a blank window like the one in your screenshot though. I wonder if anyone here has the same issue.


#3

Gwen,

The Oracle error information dialog does pop up here too, it’s just that this “phantom” window appears also. I could not trigger it yet - but it seems it does not appear when not having opened an Oracle error information dialog.


#4

I ran the following script (Table XXX does not exist).

declare
cursor dale is
select * from xxx;
begin
for x in dale loop
dbms_output.put_line(‘XXX’);
end loop;
end;
/

When running you get the 6550 message, I am able to double click that and get the little icon in the corner (See screen shot). I did not get the output window, I was able to launch it from the standard attached window.

Hope this helps.

I am also running xp professional…
smallicon.jpeg


#5

I think it works allright for you, Dale. In Dominique’s machine, he got a blank window without any message.


#6

Gwen,

No, I got exactly the same as Dale: a message box with the error description AND a small square in the top left corner of the desktop (which seems to be a KxEngine window).


#7

Sorry you guys. It’s so small I couldn’t see it.
Anyhow, I can reproduce it too. The reason is when KX.exe is running, it launches that window to interact with Nav. If you go into Task manager and kill kx.exe, that window will disappears. I don’t think it would cause any problem but if it really annoys you I would suggest to log an issue in with KX.


#8

Gwen,

It’s OK. Was just wondering what it was…