Toad World® Forums

Launching New Navigator


#1

I am going to mention this, 3 times now I have launched the new navigator and it would go to 75% cpu and nothing would ever come up. This last time I actually walked away and gave it 15 minutes and it still never came up.

Message was edited by: DaleFromLozier


#2

Hi

1- Didn’t you had another SQLNav process running (in windows task manager->process)?

I had that sometime ago (with another version) and after I killed all the “lost” processes it worked!

2- If 1 doesn’t apply maybe cleaning the infamous registry keys?

Regards

Filipe


#3

I had not checked that, but if “killing” the hung session kills all navigator then that could be it, but as soon as I kill it and re-launch it, it comes right up.


#4

Hi

Did you kill all the sqlnavigator processes? killing only one doesn’t kill the others …but maybe it will release some resource that the other process also wanted.

Maybe it’s trying to open previous connections?

did you tried to clean the uninstall , delete the registry keys and install it again?

BTW what version are you using?

Regards
Filipe

Message was edited by: Fsilva


#5

6.2.0.1476 on xp. I have not checked any of the other possibilities you have mentioned, it has not happened again. I will certainly check those things if it does happen again. Basically the session that hangs when I click the x in the upper right hand corner, wait for navigator to completely shut down and start Navigator again it starts. The only thing I can figure is that if there are “rogue” processes running it cleans them up when it goes down. If it happens again I will check these things and report on it.