Toad World® Forums

LDAP login problem in 6.3 and 6.4b


#1

NAMES.DIRECTORY_PATH= (LDAP, TNSNAMES)

Hi

When logging with LDAP:
In SQL Nav6.2.1 on logon window on LDAP tab LDAP address field is editable (LDAP descriptor list is not fetched - still no big problem…)
In 6.3 and 6.4b list still not fetched but field in NOT editable. So no access to new databases. Only through “project manager(Ctrl-W)” where old installation (6.2.1) preferences were transferred… :wink:

Any workarounds?

Toad 10.5.1 does fetch the LDAP descriptor list AND field is editable - perfect solution.

Could you please make this field at least editable.

Marko

BTW.
In SQLNET.ORA:


#2

Hi Marko,

We made some changes in 6.3 which is supposed to support multiple directory servers listed in the LDAP.ORA file. Forcing the descriptor list readonly was a side effect. We will try to fix it in 6.4 release.

It seems SQLNav has problem reading the LDAP.ORA file in your case. Could you send me a copy of the LDAP.ORA file so that we can investigate how the problem occurs? My email is vincent.liu@quest.com.

If would be great if you can also send me the support bundle:

  1. open SQL Navigator 6.2 and log on to a database;
  2. go to Help -> Submit Feedback;
  3. in the “Submit feedback to Quest Software” dialog, click “Save to File”;
  4. save the SupportBundle.dta file to your computer;

Thanks,
Vincent


#3

At the moment you have problem to get the LDAP database list, but if you know the alias/name of the database, you can type it in the Database field in TNS tab. It will work if the Oracle client that you select can connect the LDAP server.

Let me know if this works for you or not.

Thanks,
Vincent


#4

Yes, it works. (Using TNS tab for LDAP connections)

markk