Toad World® Forums

List index out of bounds (2)


#1

I tried changing my font in a sql window (data grid font actually) and when i do, I get an exception: “Exception during ShowTaskBar: List index out of bounds(2)”

I’m using the latest build: 6.0.0.864


#2

Hi Joe,

I couldnt reproduce the issue you reported. Could you please post a screenshot so I can see the layout and what’s on the taskbar?

Thanks for the feedback.

Gwen


#3

Hi Gwen,

I think it was related to the fact that I had, unknowingly, been disconnected.

Speaking of which, SQL nav 6 has been VERY buggy for me. For instance,
I start it up,
connect to the database,
Start to type a sql command`
a message pops up that says “Populating Code Completion dropdown…” (which doesn’t go away)
Then, I complete my query which happens to go to a non-existent table, and the query takes 5-6 minutes to return
Then it comes back with a “hostdef not found” or an “OCI_INVALID_HANDLE” error
and
disconnects me from the database.

Does it every single time. This is with a 9.2.0.8.0 database.

I can’t use it in this state. Do I have to deinstall my older version of SQL Nav?


#4

Hi Joe,

I normally use the 10g database for testing and I have never came accross this problem. I also set up the 9.0.2.8.0 database but I couldn’t reproduce it either.
Could you please let me know what Oracle client you are using???

if deinstall means uninstall then no you can have both 5.5 and 6 beta installed side by side.

Thanks again for you feedback,

Gwen


#5

Hi Joe,

All I can say is that you probably have an unreliable database connection (either client, or server). Installing 6.0 shouldn’t remove your 5.5, so you should have both versions and can try to reproduce the problem in either. If the problem is from an unreliable database connection, you can’t blame it on SQL Navigator. You can disable the auto-completion using the button on the toolbar (which looks like “a[ab]”), this should stop Code Editor from querying your database too often, but doesn’t guarantee you won’t have any other problems.

Please let us know if 5.5 has similar problems, or if turning off auto-completion has improved the situation.

Thanks,
Roman


#6

I don’t think I have an unreliable connection because 5.5 works fine. How do I tell which client I’m using? I have both 10g and 6i installed on my machine (don’t ask) and I’m wondering if it’s using the 6i version which is OK for 5.5 but not 6???

Joe


#7

Ok, I tried it again without the auto complete on and it seems to return quickly and tell me that the table does not exist. Then I put it back on and tried it again. It went out to lunch again, but I was able to close the SQL window. But, when I went to reconnect the session, I got a
“exception EAccessViolation in module SQLNav6.exe at 000235F6.
Access violation at address 00E01D8C in module SQLNav6.exe. read of address 3C0002A0”

Don’t know if this helps at all. For the time being I’ll try using it without the auto complete.

Also, I checked my Path and it appears that only my 10g client is in the path so I think that’s what I’m using.

Joe


#8

This is still flaky as heck. Do you think it’s the older version of the database? 5.5 runs without a hitch.

I’d like to be able to use/test the beta version, but it’s not working out at this point.

Joe

Message was edited by: joethejet


#9

Hi Joe,

We have tried very hard here to reproduce the problem, but we did not have any luck yet…
We have tried to set up the 6i envi (I assume that you meant 6i Oracle Forms/Report). The oracle client shipped with 6i forms is 8.0.6, I could not connect to any DB using SQL Nav 5.5 or 6.0…

Having both 10g and 8.0.6 client installed, I then could connect to DB using 10g client, and SQL Nav 6.0 is working fine without stability issues you reported. Still having the same conx issue with 8.0.6 client though.

I believe this issue might relate to the 6i client you have on your system. We have not heard from anyone else about this issue up to now…I hope that someone on the Community will be able to give us some light on this.

Have you tried on another PC which does not have 6i to see if you get the same problem.

Just one more note, on the machine you current have problem with Nav 6.0. Could you please create the Support bundle zip file and send it us. Please go to Help-> Submit Feedback, check the ‘Include a Support Bundle’ then click ‘Save to File’ button. Please attach the zip file with your post.

Thanks and regards,
Bruce


#10

Thanks for checking this out. It’s much apprciated.

I would love to create a support bundle for you, but I get an error message ‘Cannot open file’ when I try to save it. No file is created. :frowning:

Any more thoughts?

Joe


#11

Hi Joe,

Thanks for getting back to us.

I believe that you have a Xpert licence key with SQL Optimizer/SQL Tuning option, there is an integration issue generating SQL Optimizer support file bundle…

We will send a new SQL Nav.exe shortly so you can generate the support bundle file.

Thanks again.

Regards,
Bruce


#12

Hi Joe,

We have made changes to fix the issue with create bundle, and the changes will be in the next Beta drop for you.

If you already have SQL Optimizer Version Selector, I think it would be easier for you to do the following for the work around to get the support bundle file created for now:

  • Please make sure you close Nav & SQL Optimizer if you have them running.
  • run Start->All Programs->Quest Software->Quest SQL Optimizer for Oracle->SQL Optimizer Version Selector. Select version as attached screen shot, click Set Active then Close.
  • Run SQL Nav again, and create the support the bundle.

Please let us know how you go.

Thanks and regards,
Bruce
optimizer.jpeg


#13

Well, the option to pick version 6.1.2 is grayed out. :frowning:

When I installed version 6, I didn’t install any of the “extra” tools (e.g. data modeler, optimizer) because I already had them installed with V5 and figured I’d just use them from there if I needed to.

Maybe I should deinstall and reinstall. What process would you recommend for getting a clean start?

Thanks,

Joe

null


#14

Hi Joe,

No need to uninstall/reinstall as we would like not to change your environment. It is better for us to send you the new SQL Navigator binary.

We will try to get the new beta build to you COB today.

Thanks,
Bruce


#15

Hi Joe,
I have uploaded the new binary to the following (download size 12.6MB):
http://sqlnavigator.inside.quest.com/shares/sqlnavigator/sbin/beta/875/sqlnav_6-0-0-875-beta-update.zip
Can you please try to create the Support Bundle again.

Thanks,
Bruce


#16

yay, it worked! LMK if you have any ideas on what will help these problems go away.

Joe
SupportBundle.dta (4.33 KB)


#17

Just FYI. The new binary seems to have made things a bit more stable too. Still not perfect, but it’s usuable now.


#18

did you guys make any sense out of the support bundle? I’d like to use 6.0 and give you feedback, but it dies so frequently I’m afraid of losing work.

For example today, i’m trying so save a very simple package and it keeps disconnnecting me.

It doesn’t do that in 5.5 :frowning:

Thanks,

Jet


#19

Hi Jet,

Sorry for a late reply. I did not get email notification about your post with the support bundle as we had issues with the Community server.

I am checking the info from support bundle and will get back to you soon.

Thanks,
Bruce


#20

Hi Jet,

Can you please connect to the Oracle DB, then re create the Support Bundle again. The last support bundle you sent did not have the Oracle home and DB connection details. We would like to get these info.

Can you also please do a check of if there is any difference in the preferences bw version 5.and version 6…

thanks,
Bruce

========================================================================
** Oracle TNS Names Location **

No Team Coding sessions active.

** Oracle Client Information **

Oracle Home =

Oracle Client in Use = C:\oracle\10g\BIN\oci.dll

Company Name = Oracle Corporation
File Description = Oracle Call Interface
File Version = 10.1.0.4.0
Build Number = Unavailable
Internal Name = Unavailable
Legal Copyright = Unavailable
Original Filename = Oci.dll
Product Name = Oracle Call Interface
Product Version = 10.1.0.4.0
Product Edition = XPert Edition

========================================================================
** Connected Oracle Sessions **

========================================================================

========================================================================

End of File

Message was edited by: bruceduong