Toad World® Forums

Loading a file into a varbinary(max) field in a grid doesn't work

Hi:

I am using Toad 6.7.0.176

Steps to reproduce:

  1. I have an editor open with a script where one of the statements is: drop table schema.TableName. I highlighted schema.TableName and I pressed Shift+F4. Toad opened the table details on another tab - I set it that way.

  2. I went to the table details Data tab, I enabled the editing in the table and I selected the only row in the table. I clicked on the varbinary(max) field and Toad displayed a dropdown with several tabs: Image, Hex, Ascii, Utf-16, Utf8 and Pdf. The Image and Pdf tabs are disabled.

  3. With the Hex tab selected I clicked on the Open button (with the yellow icon), I selected a sql file, the open file dialog disappeared, then I clicked the button with the green check mark. The dropdown disappeared. I clicked the check mark icon in the grid bottom toolbar to save the row.

  4. In a different editor tab, I ran a query select * from schema.TableName where varbinaryMaxField is null and it returned the row I selected. This confirmed that toad didn’t load the file and it didn’t save anything in the varbinary(max) field.

Could you please fix this issue, in case it hasn’t already been fixed?

Thanks,