Toad World® Forums

Memory Problems in Version 5.2

Initially I have been using version 5.1 I created a model in this version.
When I used the version 5.2 when opening the model of this version 5.1 has been updated. have added more tables and open the *. txp showing errors and not to open the model.
The test was made ​​in a more resource pc i5 processor and 8GB of memory and no problems.
I think there are problems with version 5.2 in computer memory consumption low resources no longer allows large models to work on version 5.2.

Another problem is when a model with many tables has been able to work well in version 5.1. the problem is that when the model is updated to version 5.2 and can not go back to version 5.1.

That problem may be happening?

Manuel Peña

Hi Manuel,

thank you. Can you send us screenshots of the errors, please? Or if you got access violation, please send us Eureka Log.

Regarding versions: yes, model opened in newer version cannot be opened in previous version (new or modified information are stored in the new model and the previous version is not able to load unknown metadata).

Regards,

Vaclav

Hi Vaclav
I commented that the 5.2 version is having many errors, is unfortunate because it has already shown us many problems.
We did a reverse engineering a BD with version 5.1 and then we upgraded to 5.2 and have worked many changes and is now unstable.

I’m there atachando a file of many that we have sent . initially thought the problem was a low PC resources but is now showing errors with a PC with i5 and 8 GB of memory.

We are working on the model file SHAREPOINT , we opened the file editing (CHECK OUT) and open the file on the button will open the entire route we entered sharepoint . ejm ( http://xxxsharepoint/sites/Txxxt/FileName % 20ABC % 20Model % 20 - % 20MSS2008.txp )

It would be nice to test thoroughly before releasing version because as I mentioned earlier when updating the model to version 5.2 and can not return to use the version 5.1 because this version does not support an updated to version 5.2 model.

note : sorry but my English is not very good .
BugReport1.rar (101 KB)

Here I send you another error.
As I was saying shows many errors, in some cases does not leave the option of mailing.
There are bugs that try to open a model file and the screen freezes and get the message to close the program or make a debug.

Another thing I’ve noticed that when saving a change is very slow and takes to finish the upgrade.

keep in mind that the model file is in SHAREPOINT. able out there is the problem.

I hope this helps to solve the problems.
BugReport2.rar (101 KB)

Hi Manuel,

Thanks a lot for the reports, though they do not show anything specific.

You can have both TDM versions 5.1 and 5.2 installed side-by-side and if you make changes to the model in 5.2, it may be still possible to open the txp file in 5.1, provided the edits are not 5.2 specific.

Do you still have some 5.1 installation? What changes did you do to the model in 5.2? Just to find out and test possible influence.

I know about difference in display of relationships when you open model saved in 5.2 in previous 5.1.

The “performance” issues, like that freezing UI, seem to be connected with the fileshare connection, but it’s my guess only.

Regards,

Lukas

Hi Lukas,

The process we did when we moved to version 5.2 is to uninstall version 5.1 and install the 5.2 version.

I think the problem is the graphic part changes that have been made in version 5.2.

In the project we are working on now have 180 TDM tables, all related. The longer a table name is 42 characters.

  1. Here we have used the WORKSPACE several times and have had open 3 or 4 WS. each WS has averaged 40 related tables.

We worked WS opening and closing, opening and modifying tables, as there are handles graphics part I think for here comes the problem … also with the latest changes to version 5.2 more errors are displayed.

Two. The problem we had when we started working on the version 5.2 file we opened with this version of the model and made some changes … then when you have tried to work with low resources PC problems started …

We tried to go back to version 5.1 but the model file and showed us a message indicating that it is not supported and it must be opened with version 5.2.

Three. I’ve checked the zip file for errors and have seen that you can work the EurekaLog and all that makes them consume more than the TDM memory.

Note: We here at the company have a large project that handle tables 800-1000 and all related average. work averaging Workspace is from 50 to 120 related tables.

I commented that because we are concerned about using this tool on larger projects.

Regards,

Manuel

more errors…
BugReport.zip (10.1 KB)

more errors 2…
BugReport.zip (10.2 KB)

Hi Manuel,

First, I am sorry for the issues you are experiencing. I can see that you are experiencing issues on at least two machines, one of which is a considerably strong machine.

Second, though you get the Information dialog about possible incompatibility when you try to open model in TDM 5.1 and it was edited in 5.2, the model will be OK as long as no TDM 5.2 specific edits were made. I have tested this on a model of 120 entities, which is about your average size of models, when I tried changing relationship layout to use specific feature added in 5.2, and 5.1 could handle this quite flawlessly. If you backup your model and try opening it in 5.1, it will probably work OK. It is probable that relationships layout will change to straight lines due o changes in 5.2. But I will talk to QA and the dev team about this and we will probably run some additional testing based on your input and information provided.

Will get back to you soon.

Regards,

Lukas

Hi Manuel,

The Devs went through the attached logs and based on them they found one issue (change request TDM-502) with graphics that may be connected with your errors. It seems that the discovered issue appears when you have two or more designers of one Workspace open and model then becomes inconsistent. Is it your case? We have to be able to reproduce the issue in order to address it, so any hints or steps to follow to reproduce it are welcomed.

Nevertheless, we will focus on possible graphic issues and will research and test further. In fact we’re on it already.

Anyway, do you know about Test Model feature in TDM available via right-click of the model in Model Explorer? When run, the model is tested for consistency, any issues are printed in Message Explorer and if anything is found, detailed information is provided and you can try Repair Model to address the issues. When there is any problem in the model, any other errors that appear then are usually connected with it. And if any application error is thrown, it is necessary to restart TDM to avoid further issues connected with it.

Will keep you updated!

Regards,

Lukas