Toad World® Forums

Minor GUI Issue with Beta

After launching Toad 13.3 (so far all versions of the Beta) and connecting to a DB, I have Toad set to automatically launch a Schema Browser. This launches as expected, but one of the tabs I keep minimized and pinned to the left side of the screen appears to be leaving a ghost image that covers a portion of the left side of the screen as shown below:

This is easily fixed by opening one of the tabs and letting in close again. This only happens when Toad is launched. Let me know if you need any additional information to assist with looking into this issue.

Thanks Michael, we've seen that too. Not sure what's going on yet.

One other odd GUI issue I see is a bunch of spawned process windows with running timers stacked behind the main Toad GUI. I use my iPad Pro as a third monitor and disconnect it when going to meetings. This makes the PC re-render all the Apps I have open and Toad will render, but the phantom process windows will be in front of the GUI. I was in TOAD for most of yesterday and late in the day I has this happen and started moving the windows so I could count them and I got to 37 when I lost interest in counting them. Clicking the X or Close button does nothing. Luckily just clicking on the main Toad GUI pops it in front of all the little phantom windows. I did notice this with the 13.2 Betas as well. I can send a screen shot later if that would be useful.

Please do send a screen shot. I have no idea what you are referring to.

UPDATE: Disregard—rroblem could not be reproduced after reboot, I suspect Windows resource issue. Usually these show up as memory exception errors when applications stop behaving.

This may be related, or not: If I open Schema Browser, ask it to "Pop Out" window, the popped-out Schema window seems to become 'always on top'. Nothing below it can grab focus (go to top of pile) unless I fully minimize the popped-out window.

I first observed this on .132. I'm in Schema Browser only occasionally, so don't know if previous version had this issue.

This is on a Windows 10 HP laptop with HP docking station, using four screens (built-in + 3 external monitors).

I just disconnected and reconnected my third monitor and these windows were in the background. being early in the day, I know I opened the Download Manager earlier and then closed it, I used Replace and closed it, and have created 5 Views. I think these "Process Script" windows are created whenever you use Toad to Create an object via the GUI process that builds a script for you. None of the Close/Cancel buttons do anything nor does the X in the upper right of each window. The Execution Times in the windows continue to count up and will until I exit Toad. To hide the Process Script windows, I just need to click on the normal GUI and it comes up over the them. This is not the case with the Download Manager or Replace windows and the probably have some code forcing them to stay on top of the normal GUI. To hide them I need to call up a new instances of each and then I can close them.

This may only be seen by people who change the number of active monitors while staying in Toad, but could point to some kind of Resource Utilization leak as the objects really are not being cleaned up correctly when Toad thinks it is closing them.

I am on Win 10 1809 currently, but also noticed this when running 1803.

Those script dialogs are definitely a bug and we'll have it fixed soon.

The others are forms that persist but should not be visible unless actively being used. I am not sure why they become visible.

Hey Michael,

I have "Processing Script" fixed, but I'm trying to reproduce this to prevent the replace and download dialogs from appearing, but not having any luck. I have questions:

1 Does it matter which monitor you disconnect/reconnect? I don't have an iPad.
2. I assume it's the one with Toad showing on it, is that correct?
3. Is Toad maximized/minimized/neither when you unplug the monitor? Does it matter?



Hi Stuart,

Thanks but I think this is unrelated. I tried to reproduce it and for me the popped out schema browser is not always on top and behaves normally. I have seen different behavior depending on how you switch programs that you want on top (click title-bar, click somewhere inside the program, click windows taskbar icon). I hope that helps.

But right now, for me, it's behaving either way.



Here are answers to your questions:

1 - I do not think it matters, but will verify on Monday.

2 - Actually I keep Outlook funning Full Screen on my third monitor (iPad) when connected.

3 - Typically I do not run Toad in Full Screen mode as I am flipping between apps. I can test Monday to see if running it Full Screen makes a difference.

Really impressed you were able to fix the Processing windows so quickly. Hats off to you and your team.

1 Like


Additional Testing:

  1. I opened Toad, moved it to my Laptop display, connected to a DB, then created a dummy View, dropped the View, Opened the Download Manager window, closed the Download Manager window, opened an Editor window & used "Replace" then closed "Replace".I disconnected my HP monitor, leaving the iPad connected and running as an additional monitor. When I reconnected the HP monitor, all 3 types of windows again appeared (on my Laptop screen where I was using Toad), so no change when a different monitor is removed - reconnected.

  2. I then shut down Toad and restarted it, immediately went into full-screen, connected to a DB, then created a dummy View, dropped the View, Opened the Download Manager window, closed the Download Manager window, opened an Editor window & used "Replace" then closed "Replace". Disconnecting a Monitor and Reconnecting displayed all three types of windows, so no change between Full Screen and not Full Screen.

I did find an anomaly with the Replace window, in my first attempt at testing 1 above today, I used Replace to make a change in the SQL in the Create View screen. I always create my queries in the Editor to verify everything before sticking them in a View, but thought I could simplify this test. Oddly, the "Replace" window did not come up when a monitor was removed - reconnected. I then exited Toad, restarted it, and invoked the "Replace" from an Editor window, following my normal process. That made the "Replace" window appear when a monitor was removed - reconnected.

I hope these results help. Let me know if there is anything additional I can do to assist with this.

Thanks Michael. I wasn't able to reproduce this with 2 monitors, so then I tried with 3, but I still never got the hidden windows to appear.

Would you mind zipping up and sending me your User Files folder? You can send it to

Easiest way to find the user files folder:

  1. Go to Toad Options
  2. Click on "General" on the left, then "Open Folder" on the right. A windows explorer window will open.
  3. Important: Always close Toad before doing anything with User Files folder!
  4. User Files will be a subfolder in the Windows Explorer window which opened in step 2.
  5. Zip up the User Files folder and email it to me.
  6. If the email bounces because of attachment, put it on your google drive, dropbox, etc, and send me the link.