Toad World® Forums

Modifying settings.

I’ve tried to modify Options/Database-general/ Read LOBs… and get:

Quest.Toad.Exceptions.ProcessedExecutionException
There was a connect error. Check that the username and password are correct, that you have registered this user using the registration tab, and that the registered user has not been disabled
Stack Trace:
at Quest.Toad.CloudDB.CloudDBConnection.DoBeforeConnect()
at Quest.Toad.Db.Connection.Connect(Boolean notify)
at Quest.Toad.Db.Provider.CreateConnection(ConnectMediator connOptions, OpenConnectSettings openConnectSettings)
at Quest.Toad.Db.Provider.Connect(ConnectMediator options, OpenConnectSettings openConnectSettings)
at Quest.Toad.ConnectionManager.ConnectionFacade.NewConnection(ConnectMediator connectOptions, Boolean promptUIToConnectIfNeed, Nullable1 nbCreateDocumentsOnNewConnection, Nullable1 nbAddToGlobalConnectionList, Boolean bUseBackgroundConnector, ConnectionCreatedHandler onEndHandler)
at Quest.Toad.ConnectionManager.ConnectionFacade.GetConnection(ConnectMediator connectOptions, Boolean& isInGlobalConnectionList, Boolean promptUIToConnectIfNeed, Nullable`1 nbCreateDocumentsOnNewConnection, Boolean bUseBackgroundConnector, ConnectionCreatedHandler onEndHandler)
at Quest.Toad.LocalStorage.BaseLocalStorageProvider.get_Connection()
at Quest.Toad.CloudDB.Settings.CloudDBConfigControl.SaveConfig()
at Quest.Toad.Settings.SettingForm.SaveSettings()

Quest.Toad.Exceptions.ProcessedExecutionException
Unable to connect to any of the specified Local Storage hosts.

    System.Net.Sockets.SocketException
    The requested address is not valid in its context 127.0.0.1:0
    Stack Trace:
       at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)
       at MySql.Data.Common.MyNetworkStream.CreateSocketStream(MySqlConnectionStringBuilder settings, IPAddress ip, Boolean unix)
       at MySql.Data.Common.MyNetworkStream.CreateStream(MySqlConnectionStringBuilder settings, Boolean unix)
       at MySql.Data.Common.StreamCreator.GetStream(MySqlConnectionStringBuilder settings)
       at MySql.Data.MySqlClient.NativeDriver.Open()

Quest.Toad.Exceptions.BaseException
Encountered exception while processing exception

System.IO.FileNotFoundException
Could not load file or assembly 'Teradata.Client.Provider, Version=13.11.0.1, Culture=neutral, PublicKeyToken=76b417ee2e04956c' or one of its dependencies. The system cannot find the file specified.
Stack Trace:
   at Quest.Toad.Teradata.TeradataExceptionWrapper.isItTdException(Exception exc)
   at Quest.Toad.Teradata.TeradataExceptionWrapper.HandleException(Object sender, ExceptionEventArgs args) in T:\Dev\Source\ToadTeradata\Teradata\TeradataExceptionWrapper.cs:line 66
   at Quest.Toad.Notification.NotificationManager.ExceptionDelegate(Object sender, ExceptionEventArgs args)


Butter

To Butter:

Thank you for posting in Toad World!

I have attempted to reproduce this issue without success. Please verify if I followed the reproduction steps correctly:

I continuously togged and applied the "Read LOB" checkbox on and off, though no exception message appeared.

Were you able to reproduce this issue? If so, a support bundle would be helpful in allowing us to diagnose the issue.

Create a support bundle

  1. Launch Toad Data Point through the shortcut with the parameter /log=all.

  2. Reproduce the issue and ensure the error message appears (If applicable).

  3. Select Help -> Support Bundle

  4. A new tab will appear. After it's done generating the bundle, Right-click the tab -> Save File to save the .zip file to any directory of your choosing.

  5. Return to the Toad World thread and Post a Reply using Rich Formatting

  6. Compose a message

  7. Select the Options tab next to Compose, then click Click to Add to add the .zip support bundle

  8. Post when you're ready!

Software Developer I,
-Joshua Liong

Hi Joshua,

Yes, I'm able to reproduce error. I've tried to create support bundle, but... got similar error.

--
Butter

To Butter:

I humbly apologize for the inconvenience. It's particularly troublesome that a support bundle cannot be generated. I have a question:

  • What is the installation directory of this Beta build?
  • Do you have any other TDP Beta Installations present on this machine?
    It may provide clues about this predicament, as it appears to be rooted to Local Storage.

After accumulating the information, try to perform some of these workarounds and see it it may resolve your issue:

Workaround 1: Reset Local Storage
Local Storage data will be lost.

  1. Launch Toad Data Point
  2. Tools -> Options
  3. On the left hand side, select the folder "Local Storage" -> General
  4. Note the directory where Local Storage is stored. (ie: "C:\Users\Butter\AppData\Local\Quest Software\Toad Data Point Hub Data")
  5. Rename or delete this folder (ie: "C:\Users\Butter\AppData\Local\Quest Software\Toad Data Point Hub Data OLD")
  6. Relaunch Toad Data Point.
  7. Try and see if the issues reproduce themselves. Hopefully a reset fixes the issue.

If the issue is not resolved, my remaining workaround would be to reinstall the application. In this case, I may be able to obtain more information if you could generate and post your installation log file.

Workaround 2: Reinstall Beta with Installation Logging Enabled

  1. Launch the command prompt (Start -> Type "Command Prompt")

  2. Navigate to the directory where your beta build is stored.

  3. Type out the name of the executable, followed with special syntax, then the FULL path of what the log file should be saved as.
    (ie: ToadDataPoint_Beta_3.7.0.519.exe /L*V "C:\Users\Butter\Desktop\installationlog.txt")

  4. Push ENTER. It will begin the uninstall/re install process.

  5. Afterwards, attach your text log file to a post for me to review!

Software Developer I,
-Joshua Liong

Hi Joshua,
fortunately first workaround has worked ;). Here are links to both files:

https://www.dropbox.com/s/ufv1gmdu17pdli3/ToadSupportBundleToad%20Data%20Point.zip?dl=0
https://www.dropbox.com/s/hx0lkyj3gh0wued/SupportBundleText.txt?dl=0

Answering your questions:

  • What is the installation directory of this Beta build? : "C:\Program Files\Dell\Toad Data Point Beta 3.7\ - default one
  • Do you have any other TDP Beta Installations present on this machine?: No

Butter

To Butter:

Thank you for sharing your support bundle and information. I have been unable to detect any anomalies from the logs.

I am happy to hear that the first workaround of Resetting Local Storage helped out.

Feel free to post on Toad World if you ever need further assistance!

Software Developer I,

-Joshua Liong