Toad World® Forums

MS Terminal Server 2003


#1

Hi!

Can you explain how should i grant privs for terminal users, to use sqlnav on 10g client?

List of grants already done:

registry:

HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE - read

Filesystem:

%ORACLE_HOME%\ - read

Quest Software istall dir - read
Grants to execute sqlnav.

WHen I open sqlnav error occurs: unable to initialize OCI : error -1
When user has admin priv everything works fine.
Default Oracle_home is set correctly
When Oracle9 was installed on this machine there wasn’t problms with sqlnav.

Any sugestions?

Piter


#2

This is our customer’s server.I tried to simulate this situation on my server and terminal user works fine :(, without any special grants.

Can you give me any suggestions?


#3

Hi Piter,
Below is the extract of our current release note. We have a Citrix Farm in our lab here and it is working fine. I will look into it and will try to get back with more info later.

Thanks and regards,
Bruce

Terminal Server/Citrix Presentation Server Installation Notes

To install SQL Navigator on Citrix machine

1 Connect to the Citrix environment as an administrator.
Connect to the Citrix environment as an administrator.
2 If required, copy the applications to be installed to the Citrix machine.
If required, copy the applications to be installed to the Citrix machine.
3 Before installation, open a command line and execute: change user /install
Before installation, open a command line and execute: change user /install
4 Using the Windows Add/Remove program, install SQL Navigator.
Using the Windows Add/Remove program, install SQL Navigator.
NOTE: The Citrix Administrator will have to install the application on every machine in the Citrix farm. However, the application only needs to be published once.
5 When setup is complete, verify the installation by launching SQL Navigator and Knowledge XPert*/SQL Tuning*
If installed.
When setup is complete, verify the installation by launching SQL Navigator and Knowledge XPert
/SQL Tuning*
*If installed.

Working with TNS Names
To enable all of the databases defined in the tnsnames.ora to be available to all the users in a Citrix environment, use the TNS_ADMIN environment variable on each machine where SQL Navigator is published to point to the location of the TNSNames.ora file.
1 Connect to the Citrix environment as an administrator.
Connect to the Citrix environment as an administrator.
2 If required, copy the applications to be installed to the Citrix machine.
If required, copy the applications to be installed to the Citrix machine.
3 Before installation, open a command line and execute: change user /install
Before installation, open a command line and execute: change user /install
4 Using the Windows Add/Remove program, install SQL Navigator.
Using the Windows Add/Remove program, install SQL Navigator.
NOTE: The Citrix Administrator will have to install the application on every machine in the Citrix farm. However, the application only needs to be published once.
5 When setup is complete, verify the installation by launching SQL Navigator and Knowledge XPert*/SQL Tuning*
*If installed.

When setup is complete, verify the installation by launching SQL Navigator and Knowledge XPert*/SQL Tuning*
*If installed.

Working with TNS Names
To enable all of the databases defined in the tnsnames.ora to be available to all the users in a Citrix environment, use the TNS_ADMIN environment variable on each machine where SQL Navigator is published to point to the location of the TNSNames.ora file.


#4

Thanks Bruce, I will check this…


#5

We found some info from Oracle doc on 10g clients of which you will need to do some extra tasks after the installation as specified below.

Hope that it would fix your customer’s problem.

Hi Piter,

If Oracle client works on the machine but not 10g. I think your issue is similar to problem which user bscalzo reported a few days ago on his 64bit OS environment.

In SQL Nav we have the home selection and we force oci.dll and related dlls unload/load at run time.
Thanks and regards,Bruce ■ From Client Admin InstallInstead of copying libociei.so or oraociei10.dll from theORACLE_HOME/instantclient directory, copy libociicus.so ororaociic10.dll from the ORACLE_HOME/instantclient/light directory.That is, the Instant Client directory on the LD_LIBRARY_PATH, in UNIX, shouldcontain the Instant Client Light data shared library, libociicus.so, instead ofthe larger OCI Instant Client data shared library, libociei.so. In MicrosoftWindows, PATH should contain oraociicus10.dll instead oforaociei10.dll.■ From Oracle Universal InstallerIf the Instant Client option is selected from the Oracle Universal Installer, thenlibociei.so (or oraociei10.dll on Microsoft Windows) is installed in thebase directory of the installation which is going to be placed onLD_LIBRARY_PATH. This is so that Instant Client Light is not enabled by default.The Instant Client Light data shared library, libociicus.so (ororaociicus10.dll on Microsoft Windows), is installed in the lightsubdirectory of the base directory. Therefore, to operate in the Instant Client Lightmode, the OCI data shared library, libociei.so (or oraociei10.dll onWindows) must be deleted or renamed and the Instant Client Light data sharedlibrary must be copied from the light subdirectory to the base directory of theinstallation.For example, if the Oracle Universal Installer has installed the Instant Client inmy_oraic_10_2 directory on LD_LIBRARY_PATH, then one would need to dothe following to operate in the Instant Client Light mode.cd my_oraic_10_2rm libociei.somv light/libociicus.so .Note: All the Instant Client files should be always copied or installedin an empty directory. This is to ensure that no incompatible binariesexist in the installation.

Message was edited by: bruceduong


#6

Hi Bruce,
I think that its about privs, that when I add user to admin group , everything works fine. This server is connected to domain with special privs, that could be problem to. When I simulated teminal session on my server (not in domain) everything works. So if i find something , let you know.

Regards Piter


#7

Hi Piter,

Have you tried to add the user to ORA_DBA group instead of Administrators group. Hope that is all you need to get access to Oracle client.

Pls let us know if you make any progress. I will check with Sekhar and Tim on Monday if they could provide any more light on this.

Thanks and regards,
Bruce


#8

Hi!
Thank for sugestions, but there is installed only oracle client sotware, ora_dba group not exist. So i will try create and add users to ora_dba group, let see if this help. I will test it monday.

On my test sever is installed full Oracle Enterprise version, and sqlnav works without problems on terminal sessions.
If I resolve this issue , let you know.

Regards Piter.


#9

Hi Piter,

Sekhar asked me to forward this info to you. Sekhar is currenlty having some problem loggin the Forum.

Pls try the following:
It On the remote server: 1. Select Administration Tools , Local Security Setting and Local Policy.2. Then select "User Rights Assignment"3. Double click on "Create Global Objects"4. Select Add User or Group.5. Make sure Object Types Group Box is checked.6. Select Locations and highlight the name of the server you are working on (Not the Domain).7. Enter “Remote Desktop Users” (without the quotes) into the Object Names Box.

  1. Select OK.

Pls keep us posted.

Thanks,
Bruce
On behalf of Sekhar.


#10

Hi!
This setting was already done, but error still occurs. I think that domain blocks something more. Unfortunetly I can’t exclude srv from domain for tests. If I find something let U know. I reinstalled Oracle to ver 10.2.0.2 Full Ent Edition, without results :frowning: .
Strange, on Ora 9.2 it was working properly. In 10g structure of registry changed but what else? Maybe oci.dll try to load extra libraries from system and users cant access them ?

Regards Piter.


#11

Hi Piter,
Sorry for a late reply. I was away sick yesterday, and was not feeling well the last few days.

We will keep you posted if we could think of anything else…

Thanks and regards,
Bruce


#12

Hi Piter,

Could you try to connect using SQL Plus to see if it would connect successfully…We just would like to determine whether it is envi related…

Thanks,
Bruce


#13

Hi Bruce!
Yes SQLPlus not working too, SP2-1503 SP2-0152 errors occured for sqlplus, and program couldn’t even start. I thing - privs are to small.


#14

Hi Piter,

Thanks for the update.

Will leave it to Sekhar who will assist you with this :-). Sekhar is still looking into this for you with the help from our domain expert.

We will keep you post if we make any progress :-).

Thanks,
Bruce