Toad World® Forums

MSSQL + Domains + UniqueUdentifier issue


#1

Hi There.

In a MSSQL model, when I create a domain that is of a type “UniqueIdentifier”, and I then use that in a table, I cannot set the “Row GUID Column” flag. This is only an issue with 5.3. In the older 4.3 it worked fine.

Please fix, this is a very important thing that we must do in a large model we are working on for a new project. The work around is to change the fields from using a Domain to just a standard data type, but that is not ideal.

Thanks


#2

Hello Jason,

I’ve tried it out and it is as you say. Our devs will take a look at it, so it will be probably fixed in the next version of TDM.

Thank you for your patience and for letting us know.

Regards,

Lukas


#3

Hi Lukas

What is the general time-frame for the next update with this fix?

And, how to I claim my free T-Shirt? You give away swag for finding bugs right? :wink:

-Jason


#4

Hi Jason,

the next official version is planned for next year, however many fixes for known imperfections as well as various improvements will appear in beta releases.

Re T-shirt: it depends on product communities. Currently there is no active Reward Program for Toad Data Modeler community.

Thank you,

Vaclav


#5

Next year, as in “early” next year? Will it be a 5.x release (5.4), or the next version: 6.0?

I was joking about the shirt… mostly. :wink:

-Jason


#6

:slight_smile:

The next release will be published in April (certainly not April 1st) and it should be version 5.x, not version 6.0.

Thanks,

Vaclav