Multiple bind values (resulting columns in grid are empty)

Since 9.2 version (I think!) and now in last one 9.3.0.706,, however I use multiple bind values, regardless type of "Execution Method" I use, I get all the time empty columns in grid result.
Please look at the picture bellow.


I know that very right columns are invented for traced sessions, but now I have all the columns empty and this is not normal to me.
How to run SQL Optimizer to get somehow "old way" of working, where at least dozen of columns were filled (and all others were "-1" if you remember previous version how it works)?
Brg
Damir

Any news on this topic?

hm anyone alive that can answer this question

Hi Damir,

The columns that you are refering to are the "Session Statistics" retrieved from the SYS.V_$MYSTAT and SYS.V_$STATNAME while running the SQL with TIMED_STATISTICS set under your session. Please check and make sure that you can access the SYS views using your login user.

I have tried and cannot reproduce the problem on my side. So if you do have access to the SYS views above and still cannot see values in those columns, please contact Support for more detailed investigation. A Support Bundle and capturing of the executed SQL from SQL Tracker would be helpful.

Thanks,
Alex

Please check and make sure that you can access the SYS views using your login user.

Ok now I see where he problem is...

unfortunately, many users that run queries are not so powerful, and now there is no way to get those interesting data.

So if you can, please reorganize SQL Optimizer to able to connect as some power user anbd then to choose PARSING_SCHEMA, which will actually do:

ALTER SESSION SET CURRENT_SCHEMA=XXX;

in this way all power sys tables will be accessible and we do not have to change queries because all private synonyms will be active....

Is this possible to add as way of work:

  1. work as ordinary user (as it is now)

  2. work as power user (and alter session later)

This would be the best.

Hi Damir,

Good to know that the problem is now resolved.

What you described as "work as power user (and alter session later)" is already available in SQL Optimizer. Under a SQL Rewrite session, on its top-right corner, you should see a Schema dropwown beside your connection string. Setting the schema there will alter the current schema in your session. Hope this help.

Thanks,
Alex

Hi Alex,

This is just great.

Sorry but wasn't aware of it until now...how to teach old dog new tricks...is mine favorite.

:slight_smile: