Toad World® Forums

No auto completion for tables and columns with Toad for Sybase 2.0.0.201

Hello !

I tried today Toad for sybase 2.0 (I was used to work with Toad for Sybase 1.3).

It seems pretty cool, but I can’t use the cool auto completion feature.

It doesn’t work anymore, so I rollback to the version 1.3.

I tried to restore to default my Options, but it’s change nothing.

When I hit CTRL + ., the dropbox open and propose a list a DB users, but no completion for my tables or my columns.

What i am doing wrong ?

Thanks !

Hello Thomas,

Could you please send the screenshot or script to me so that we know exactly where the problem you encounter is? My Email address: cindy.sang@quest.com.

And we have a patch version released, you can use this newest version to see if code completion works.

Download URL: support.quest.com/softwaredownloads.aspx

Thanks,

Cindy

I submitted a support request (don’t remember the number), and the problem was verified with Toad Support. Unfortunately, I can’t find any of my email correspondence with them. I’m pretty sure Dexter Chen verified that it worked improperly.

What I discovered was if the the sql statement was the only one on the editor page, the autocompletion worked properly. If, however, you had other scripts above the one you want to autocomplete, all you got was a list of users. Very frustrating. And there’s still a handful of annoying omissions still pending.

I had some scripts above the one need to autocomplete, however I cannot reproduce it with 2.0.0.201. Could you please send your script to me? as this issue might be related with specific script. Likely, you mentioned there’s still a handful of omissions still pending, could you also tell me what omission problem you get if it’s not reported yet?

Thanks and regards,

Cindy

Here’s a screenshot of autocompletion failing.

autocomplete.png

In the above screenshot, I am logged in as DBA.

I’m not able to consistently recreate this scenario, but I am seeing issues with auto-complete in general. We’ll look into this further for our 2.1 release.


This is for TOAD For Sybase 2.x

Solution to this i found out —

Autocompletion doesnt work:

select * from schema…tablename …

Works for:

select * from schema.owner.tablename …

Toad requires you to give ownername to automate the autocompletion with drop down of tablename, columnname, view / objects.

Hello,

I just want to verify that all the CC issues here are for SQL Anywhere connections. Is that correct?

Hello, Michael. For me, yes.

The 2.1.0.2921 release is much better. Still wish it would give a list of @ and @@ variables after a ‘set’ or ‘=’ command. Nothing after ‘set’. The usual list of users and dbo and SYS tables after an ‘=’.