Toad World® Forums

Notes 2 on beta R8 (build 864)


#1

Some differences compared to 5.5 where 6.0 seems to have lost some functionality

  1. In a package body the Code explorer doesn’t highlight any more in which procedure the cursor is in.
  2. Ctrl + Enter inside package body doesn’t jump to local procedures any more.
  3. editing table data has changed. It seems that when i edit the data in cells, the only way to actually carry out these changes is to commit. If i accidentally run another query in the editors, my changes are lost. And if i don’t want to commit right away, i have to make my changes in different editors and commit all of them together. But when i need data from one row (generated by trigger(sequence)) to insert to another table, i’m stuck. I can’t use the marvellous “duplicate seleted rows”, i’m back to writing insert-select scripts. Maybe a new button (apply changes, but don’t commit) would not make things too complicated?
  4. Column formatting is not remembered - when executing new query, it always jumps to “N&D” (Format columns by names and data), although “D” (Format columns by data width) or “Def” (Default solumn formatting) was the last thing clicked.
  5. Default column formatting is something different than in Navigator 5.x. It used to be the best fit, now it’s consuming very much space (columns are unnecessarily too wide). Also “N” option is gone (format by name), but i miss the default formatting one.
  6. The new code editor doesn’t run selection (it’s very useful when debugging “select columns from (select columns from (select columns from …) where conditions1) where conditions2” -like sql statements)
  7. In the result set, there is no row number any more

#2

Hi Andres,

We definitely missed out on some functionalities here. You really did a good job spotting them out.

1,2,4,5 we will discuss and make changes accordingly.
3. I have asked Roman about this just to make sure I dont miss anything and he confirmed that 5.5 and 6 behave the same way. When you accidentally run another query, it will prompt you to commit the changes. can you please elaborate more on how they are different?
6. The functionality works fine for me. Just highlight a piece of code and click run or f9, right?
7. To display the row number, go to Columns tab inside the Toolbox and select Row#

Gwen

Message was edited by: Gwen

Message was edited by: Gwen


#3

Hi Gwen,

  1. Might it be because i imported by preferences from 5.5 during the install? In 5.5 i turned off the Confirm DB updates in Grid option, because i used it frequently. But even now, when in 6.0 i turned it back on, no warning at all - just the update i made is gone, when another query is run. By the way, here in Preferences => code Editor => sql Scripts i noticed an option to Show Row #. I checked it, but nothing happaned - no row number in query results turned on by default. (see my 7.)
    I tried with a small table, and it really worked as you said it would. Then i tried with a bigger table (more than 250 rows so not all of them fetched) - no warning, updates lost. Tried the small one again - updates lost. Closed SQL Navigator, opened sql navigator, connected, tried with a small table - updates lost.
    CREATE TABLE at_test5
    (kuupaev DATE,
    dummy VARCHAR2(1))
    /
    insert into at_test5 values (to_date(‘24.05.2005’, ‘DD.MM.YYYY’), ‘X’)
    /
    insert into at_test5 values (to_date(‘23.05.2005’, ‘DD.MM.YYYY’), ‘X’)
    /
    — turn updatable on
    select * from at_test5;
    — double click on the first dummy, change from X to Y, click OK (the row becomes blue (updated), very nice, click on the select statement in the editor, click execute step - no warning, just two rows with X in dummy.

I tried some more times. It seems, that executing and reexecuting the query using “Execute to end” button (F9) usually produces this warning. using “Execute step” button (F8) usually doesn’t produce this warning. As i usually have 10 or 20 or 30 sql statements in one editor, i rarely use F9 - i want to execute one statement at a time - and these checks seem to fail here.

  1. I tried the F9 and it works, yes. Seems that i always run things with F8, this one doesn’t honour the selection any more. Seems F8 has lost functionality again?
  2. Thanks, there it is, i thought i had spotted it somewhere. But it is not remembered. I have to go there each time.

New things
8. In table editor (when looking to an existing table) the extract ddl button is gone … but fortunately i could drag it to the toolbar from the menu customizing section.

Andres


#4

Hi Andres,

3.I did a quick test and it seems to me that when executing with F8, it doesn’t bring up the warning. We will fix that.

6.We had a discussion about executing selection using f8 yesterday. According to Roman, F8 is only for executing a current statement and it’s not supposed to execute selection. However, sometimes you can execute selection with f8, sometimes you can’t. So there’s definitely a bug here but even if it’s fixed, it wouldn’t let you execute selection with F8.

7.Yes, there is a bug with the preference to turn on row#.It will be fixed

8.I think the reason for that is because we simplify the toolbar. We get rid of a lot of the buttons but the user can always turn it on by customizing the toolbar. I don’t think it’s a problem with the table editor.

Thanks heaps for your feedbacks
Gwen


#5

Gwen wrote:

/—/

6.We had a discussion about executing selection using f8 yesterday. According to Roman, F8 is only for executing a current statement and it’s not supposed to execute selection. However, sometimes you can execute selection with f8, sometimes you can’t. So there’s definitely a bug here but even if it’s fixed, it wouldn’t let you execute selection with F8.

/—/

But why? Why is this changed? I like the 5.5 behaviour here.
I’ll try to make up an example. Suppose there are the following three lines in the editor (any insertable tables will do):

insert into at_test5
select * from at_test5;
select * from at_test7;

Now i select the two last lines. And you say, that when i press F9 (Execute to end), it’s correct to execute two selects, and when i press F8, it’s correct to execute the insert despite of the selection? There is even more ambiguity here - if i select from top to bottom, the “current statement” will be “select * from at_test7”, but if i select from bottom to top, the current statement will be “insert into at_test5 select * from at_test5”. This doesn’t seem right to me. I use F9 only when i have a bunch of ddl/dml generated from somewhere. All other times, i use F8, meaning to run only one statement at a time. Now you are saying that when selection is used, i should use F9, otherwise F8. Two buttons for one thing, why. I want to stay away from F9 usually, there are often plenty of inserts/selects/deletes/truncates mixed in my sql editors, and i don’t want to risk running them all from top to bottom. So i don’t like the idea i have to use F9 when using selection.

One more place where 6.0 doesn’t like F8 any more:
i have a sql script in a killed/timed-out session. In 5.5 I tried to execute on statement (in the middle of the script) - i get
ORA-03135: connection lost contact
i try again, i get
ORA-03114: not connected to ORACLE
then i try again, reconnect happens and i can see the result
Now in 6.0, after the first attempt to execute and the first error message, the “Execute step” button (F8) gets disabled?! So i have either

  1. go to the end of the script and find safe / write new sql statement that can be run with F9… or do a selection?
  2. open Session -> Reconnect
  3. think, that although the button on the screen is disabled, maybe if i press F8 on the keyboard, it’ll still work?
    All these take more time than if i could just click the Execute step button again (i have the mouse and finger in position already…), like in 5.5

Thanks,
Andres


#6

Hi Andres,

We had a discussion about F8 and F9 again. Note that when there’s a selection, the function of F8 (Execute Step) becomes ambiguous: which step? the one at cursor, or within selection? what if the selection contains several statements?

We decided to take a simple path - like in v5.5. That means, when there’s a selection and F8 is pressed, it will run the first statement inside the selection. This solution isn’t perfect, but should satisfy most users.

Regards,
Roman


#7

Thanks, it makes sense to me (i mean, nothing can be changed, even cursor moved when there is the selection. so when there is selection, it must be the last thing made in the editor. and why would i do a selection and just after that want to execute something not in the selection)

thanks again,
Andres