Toad World® Forums

One less user


#1

Salut.

There was a lot, a lot, a lot of excitement until the moment to save and go do something else…to come back and only to find out that the model won’t open no more and that the work is lost…

Reopening it on a clean XP(just XP SP2) running on Virtual PC2007 gives the same behavior.

See files of errors and model in attachment.

Would it be more adequate to post more clearly somewhere on the Beta site, to not use the beta version for work that you cannot lose, if there is such work?

corruption.zip (59.8 KB)


#2

one less user refers to this perticular beta version, not one less user of TDM…TDM will probably stay one of my prefered tools for doing database design…


#3

PERModel - CodeGenerators - PERCodeGeneratorMS05 - SelectedObjects.

  1. From the SelectedObjects, delete all Id nodes.

Again, I’d like to thank you for your bug notification. TDM 3 is still under development, and we released its BETA to have enough time to test it properly, fix reported bugs, implement customers’ enhancement requests…
You’ve just helped us to find another bug and we thank you very much for this. I do hope this bug has not discouraged you from further testings of TDM3 BETA.

If you have any questions, please write me back. Thanks!

Vladka & all TDM Team

Hello,

We’re very sorry you have encountered such problems with BETA.

Thanks to your bug notification we have found another bug to fix in the Beta.
We’ve managed to simulate the problem and found solution. We have already corrected your model (will be sent to you).
(Note: Other errors, which appeared, were caused by the bug.)

At the moment we’re doing further testings as it seems that there can be more possibilities how to get to the problem. (CR # 33 547)
So, if you keep working with the corrected model in current BETA, it might happen that the problem will occur again.

If this happens, please take the following steps to fix it:
!This applies also to other users who will encounter the same problem.!

  1. Open the model in any XML editor.
  2. Look for the following node:

Added CR number.

Message was edited by: vladka


#4

vladka wrote:

You’ve just helped us to find another bug and we thank you very much for this. I do hope this bug has not discouraged you from further testings of TDM3 BETA.

Message was edited by: vladka

It did was a stopper, but this kind of support compensates for it and another go will probably be given to it…


#5

I’m very happy you’ve decided to give us another chance to convince you that our new TDM 3 is worth testing.

As I’ve written, it is still BETA and therefore some problems and bugs appear. - We are grateful for all notifications and bug reports, and do work very hard to fix them as soon as possible.

Thank you very much for taking the time to check out our new product, and giving us your feedback.

Have a nice day.

Vladka