Toad World® Forums

Oracle 9i XML model import


#1

I have a model created in TDM Freeware (2.25.0.10f). This is Firebird model.

I have made the conversion to Oracle 9i model (also using the same TDM Freeware) and made the export to XML model (.dmx file).

Then I tried to open this file id TDM 3 Beta, but this operation failed with the message: “Database 200 is not supported”.

Have you changed DB numbering in TDM 3 or maybe that is the compatibility issue between Freeware and commercial version?

Regards,
Marcin.


#2

Hello Marcin,

Let me inform you that import of Oracle 9i models (DB 200) is not supported in BETA for the time being.

Please export your Firebird model to Oracle 10g database in the TDM2 Freeware and then open the .DMX file in TDM 3 BETA. This will work.

If you have any questions, please write me back. Thanks.

Regards,

Vladka


#3

Hi Vladka,

I have made a conversion in TDM Freeware to Oracle 10g. Now I can open the new .dm2 file in TDM Freeware and I can see, in the model properties, that the DB type is Oracle 10g.

After exporting to .dmx file, I can still open the file in TDM Freeware and work with the model but when I try to do it in TDM 3 Beta, I can see the message “XML cannot be read!”

Regards,
M.


#4

Hello,

I’ve just tested the Oracle 10g import from TDM2 Freeware and it works for me.
Nevertheless, we already know from one of our customers that if there are some user permissions in the TDM 2 model, a problem occurs during the import to TDM3. - This is a bug and we’ve already fixed it. (It will be implemented in next BETA release.)

So, please delete all user permissions in your TDM 2 model if there are any, export the model to XML and then try to import it to TDM3 once again.

If the problem remains, could you please send us your .dmx file? It will be used for the testing purposes only. It would help us identify the problem. Please send it to: modeling@quest.com. Thanks for your co-operation!

Regards,

Vladka


#5

Hi all,

Conclusion to this issue: Some invalid character has been found in the XML, which caused the trouble.

Problem has been resolved and Oracle 10g .DMX file from TDM2 has been loaded properly in TDM 3 BETA.

Vladka


#6

Hi All,

The source of the error was improper characters encoding.

In my case, I should have change characters encoding in TDM Freeware before I had exported the model to XML (.dmx file). I have set “XML header” field in File -> Options… -> General to “<?xml version="1.0" encoding="windows-1250"?>” and TDM 3 is able to load the model.

Regards,
Marcin.


#7

Hi Marcin,

thanks for your contribution! What was your previous XML Header definition in TDM2, please? The following: <?xml version="1.0" encoding="windows-1250"?> is the default value in TDM2.

Thanks,

Vaclav


#8

Hi Vaclav,

Previously the XML Header field in TDM had been set to <?xml version="1.0" encoding="utf-8"?>. Propably I had changed this value some time ago and then forgot about my own changes :slight_smile:

I don’t know the default value of commercial TDM2, but TDM2 Freeware installer (2.25.0.10f, temp. v2.29) has set the encoding type to iso-8859-1 by default, not windows-1250.

Regards,
Marcin.


#9

Hi Marcin,

yes, you are right, thank you! I think I did the same thing: had changed this value and then forgot about it…

Vaclav