Toad World® Forums

perforce client setup


#1

I am unable to set up my perforce client with Toad 12.1 64 bit. No workspaces are being found. However, from my perforce client, I can see my workspaces.


#2

Is your Perforce client 64-bit? If your Toad is 64-bits then your Perforce has to be 64-bits

From: ServiceAccount_Toad [mailto:bounce-ServiceAccount_Toad@toadworld.com]

Sent: Wednesday, January 22, 2014 2:01 PM

To: toadoracle@toadworld.com

Subject: [Toad for Oracle - Discussion Forum] perforce client setup

perforce client setup

Thread created by ServiceAccount_Toad

I am unable to set up my perforce client with Toad 12.1 64 bit. No workspaces are being found. However, from my perforce client, I can see my workspaces.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


#3

Hello,

I have tested Toad 12.1 64 bit with the 64 bit Perforce Client and Toad retrieves work spaces.

We probably need more information to provide more meaningful assistance. Let’s look check some settings.

First, open Options – Source Control – Settings. This will open the Perforce configuration dialog. In the General Tab, verify that the Server Name and Port
are correct. In the options tab, temporarily uncheck everything, except ‘Only load server workspaces for the logon user’. This limits the result set to the username you enter when logging in.

Next attempt to connect to Perforce from Toad. You must enter a valid user name and password. Click the Reload from Perforce button. The ‘Attach to Perforce
Workspace’ dropdown list should populate. Mine defaults to the first workspace on the list. When you run this command once, Toad saves the workspace information locally. You should be able to work without automatically reloading the workspaces.

If none of this works, test this command from your command line. This is the command that Toad uses to retrieve the work spaces.

P4 –u yourusername –P yourpassword -p yourserver:serverport clients

This should generate a list of workspaces. If not you might be able to tell what is causing the command to fail.

Hope this helps

Stephen

From: Brad Boddicker [mailto:bounce-ButtonPusher@toadworld.com]

Sent: Wednesday, January 22, 2014 2:33 PM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] perforce client setup

RE: perforce client setup

Reply by Brad Boddicker

Is your Perforce client 64-bit? If your Toad is 64-bits then your Perforce has to be 64-bits

From: ServiceAccount_Toad [mailto:bounce-ServiceAccount_Toad@toadworld.com]

Sent: Wednesday, January 22, 2014 2:01 PM

To: toadoracle@toadworld.com

Subject: [Toad for Oracle - Discussion Forum] perforce client setup

perforce client setup

Thread created by ServiceAccount_Toad

I am unable to set up my perforce client with Toad 12.1 64 bit. No workspaces are being found. However, from my perforce client, I can see my workspaces.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

Image removed by sender.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


#4

still having issues its 2018 , and the issue seems to persist. Any ideas?


#5

Hi gauravg,

Can you provide more information on what you’re seeing? Are you making sure that if you’re using a 64-bit Toad version, you’re also using a 64-bit Perforce client (or 32-bit Perforce client with a 32-bit version of Toad)? Have you tried Stephen’s suggestions above?

-John