Toad World® Forums

Please format the XML in .tim files!

Please, could you format the XML in the .tim files created by the import wizard?

When there are field length errors because too few rows were sampled I’m finding the fastest way to fix the issue is to simply open the .tim file created by the export wizard and edit the lengths there.

But the .tim file you create is unformatted XML – one big long run-on sentence with no carriage return/line feeds.

like this:

<?xml version="1.0" encoding="utf-8"?><NewTableDefinition NewTableName=

What I want is formatted XML like this:

<?xml version="1.0" encoding="utf-8"?>

Nicely stacked, nicely indented, easy to see my datatypes and quickly make the changes I need to make.

My work around for this is to use Notepad++ with the XMLTools add-in installed and then press the keyboard shortcut they have: CTRL+ALT+SHIFT+B to format the XML – which works, but it’s outside of Toad and a waste of time.

Please format the XML, it should be an option in the tool you’re using to generate the XML in the first place.