Toad World® Forums

PLS-00103 error in test code


#1

I’m getting the following error when I try to run a test case:

PLS-00103: Encountered the symbol “[” when expecting one of the following …

Here’s the snippet that it is erroring on (the 1st line of the body):

Declare
l_result BOOLEAN DEFAULT TRUE;

l_message VARCHAR2(32767);

l_dummy PLS_INTEGER;

BEGIN

[tf_get_data_name_nopkg] (‘Q##function_return_value’, Q##function_return_value, [nt_from_fp_cv_nopkg], [fp_count_nopkg]);

I would just send a support bundle, but our development network is not connected to the internet and we don’t have a transfer mechanism.

Any suggestions?

Thanks,
Mitch


#2

Mitch,

What version are you on and what kind of test is this happening on?

Is it for a test that was working previous to an upgrade, or a new test?

You an save a support bundle to a file, instead of emailing it out directly.

Then perhaps you could find a way to send me that file?

steven.feuerstein@quest.com

Thanks, SF


#3

Mitch, I also just did a search in the forum, because that error was familiar to me, and yes, we just had another person report the same issue:

http://unittest.inside.quest.com/thread.jspa?messageID=30299&#30299

His problem was that his query contained an embedded CURSOR call, which we cannot currently support.

1.8.4 will check for this scenario and raise a warning before you get this far.

SF


#4

Sorry for the delay in my reply …

I’m running version 1.8.2.374 with Oracle 10g R2.

The specific test case I was running accepts an XML doc as an argument and returns a SYS_REFCURSOR. I have 2 outcomes set up: (1) check the row count of the refcursor and (2) check row count of a table.

I’ll see if there is any way I can get some files emailed to you (I’m not holding my breath).

Thanks,
Mitch


#5

Mystery solved (for the most part) … I found that the rows in the returned refcursor had changed since the test case was created. I’m not sure why it was failing in the place it was, but once I corrected the query defining the columns of the refcursor everything worked fine.

Thanks for your time!
-Mitch


#6

Thanks, Mitch. I will look into why that problem surfaces in this situation. We need to give you better feedback!

SF