Toad World® Forums

problem in accessing the collections (TYPES) which are defined as table of some data type/object.

Hi,

When I login into some schema through code tester for oracle, I am not able to view the TYPEs which are defined as TABLE OF some data type or record. e.g . CREATE OR REPLACE TYPE “COLTYPE_ID” IS TABLE OF NUMBER(10).

If any input/output variables are used having such data types then I can not run the particular procedure/function as it gives ORA ERROR: ORA-00931: missing identifier.

Please let me, whether there is some setting for that or it is the limitation of current version(2.6.1) of code tester tool.

Due to this problem I can not dare to switch over to code tester from utPLSQ.

Thanks and regards,

Pramod

It can access the types which are created using FORCE kayword. but if that is the case then we will have to create all views using FORCE and it will not always be possible if it comes to testing existing procedures.

Hello garkar,

I have the Quest Code Tester 2.6.0 installed and I cannot reproduce your issue. I have a simple function using your type (without FORCE keyword) as an input variable:

Then I'm running the program with the following setup:

The outcome from the run is:

And it can be saved and later run as a test:

I'm connected to the Oracle 11 database with the Oracle 11 client.

Hi, Fero

Thank u for your response. Actually I had shared only my observation, I was not very sure why I was getting the error.

Now I got the root cause after further analysis. The error ‘ORA-00931: missing identifier’. is thrown due to the following type of query in our code.

e.g. SELECT COLUMN_NAME

INTO VARIABLE

FROM TABLE ( PI_COLLECTION);

This tool internally calls the procedure “do_resolve_name” and this procedure in turn throws above error if queries like this are used in the code.

If I will use any other table name without using TABLE() type casting it doesn’t throw the error. So can’t I use this method to access the collection data, if I have to use code tester?

Please reply with the solution for this problem.

Thanking You,

Pramod Garkar.

Hi garkar,

actually I’m a new development team member, so I thank you for your analysis.

[:)]

The good news is that I can reproduce the issue now. Indeed the internal procedure do_resolve_name is the cause of failure. It calls DBMS_UTILITY.name_resolve with the argument ‘TABLE(PI_COLLECTION)’ and it fails. The bad news is that it looks like you have to wait for the next release that could deal with this issue. Since you have a nested table in the FROM section of your SELECT statement, it can’t be worked around.

However I can’t see how the FORCE parameter mentioned in your initial post influences the error appearance.

Hi Fero,

Thanks for your prompt attention to the issue.

As I said in my previous post, it was my intermediate analysis. Initially I thought that issue is due to the force keyword but after further analysis now I found that it is due to the use of Table() type casting. It took time for my analysis as I don’t have the access to internal code of the tool. I reached to this analysis by trial and error method.

Can u please suggest the tentative date of the release version in which this issue will be fixed, because we are planning to introduce this tool in our system for testing.

Looking forward for the fix in shortest possible time span.

Thanks and Regards,

Pramod Garkar

I tested the new release 2.6.2.945 and the Oracle error is not showing up anymore.

Hi Fero, I want to try this new release version 2.6.2.945 of code tester. Where I can get trial version of the same?

Oh, well… The product publishing is always few steps behind development.

You should soon be allowed to download a Beta (CTO version 949 or later). Beta program will be available on the top right of this web page, when clicking on the Beta, that is now stating “There is no beta program currently.”

The Beta program should be available in a few more days.

Can you please provide tentative dates …

The Beta program is now ready. It’s been just a few days (maybe weeks, time passes too quickly :slight_smile: ) late, sorry for the inconvenience

Hi,

I tried to install the beta version but got error: “Your installation of Dell Code Tester BETA has expired.”.

screen shot.jpeg

I tried using latest downloaded file.

Please help

Hi garkar,

sorry for the troubles… Looks like we made a mistake in uploading the new versions to the new publishing system. Please try again in a couple days.

And thank you for trying the Beta.

Hi,

I am exploring the beta version and we are planning to integrate the test cases generated by this tool into build system (Teamcity) for continuous integration .

But I am not able to import the .xml test files (exported from the code tester for oracle). I am getting error “LPX-00231: invalid character 33 (’!’) found” when I try to import the file. This character is present in the automatically generated export file.

I tried to import using the command line approach but got the same error.

Please help me in resolving the issue

.

Thanks and Regards,

Pramod Garkar.

Mail: garkar@optymyze.com

[View:~/cfs-file.ashx/__key/communityserver-discussions-components-files/71/0245.screen-shots.docx:550:0]

[View:~/cfs-file.ashx/__key/communityserver-discussions-components-files/71/6521.Q_23002300_PRAMOD_5F00_SPM_5F00_130.TEST5.xml:550:0]

[View:~/cfs-file.ashx/__key/communityserver-discussions-components-files/71/4454.test5.txt:550:0]

Hi Pramod,

thank you for using the Code Tester and helping to improve.

The exported XML document contains formatting hints < and > My environment does export to a document containing appropriate markup code: < and > . My exported XML document is imported correctly, without errors. When I change your exported document and replace all formatting hints with corresponding signs, your XML document is imported without errors as well.

I checked the new beta version 2.6.2.960 that is available… And the XML format was correct when I exported the test. Hope it is solved already and it was a intermediate misbehavior in the previous version that you have used?

Best regards,

Ferda

Hi Garkar,

Unfortunately the Beta 2.6.2.951 that you are using has a bug and creates wrong export files.

I propose you to do 2 things:

  1. Go and download newer Beta 2.6.2.960.

  2. Please use 6521.Q##PRAMOD_SMP_130.TEST5.xml that I have fixed for you.

[View:~/cfs-file.ashx/__key/communityserver-discussions-components-files/71/8420.6521.Q_23002300_PRAMOD_5F00_SPM_5F00_130.TEST5.xml:550:0]

Many thanks to Leok and Fero for your replies.

This issue is resolved in newer Beta 2.6.2.960.

Hi,

Till when we can get the final release version of code tester which will have all the fixes of Beta 2.6.2.960. Or is it already released?

The Code Tester 2.6.2 is now GA.