Toad World® Forums

Problem on Report Generation



I just done a silly action, but i would be grateful, if you can fix it as well.
I tried to generate the report( I have not checked close Wizard after Execution checkbox), after generated the report,
I accidentally click on execute button again, which will overwrite the Report which just generated. While it is generating the same report with same name as the previous report it generated just now. Toad Data Modeller return an error message (Please find the attachment for more information)
After the report is generated (the overwritten one), I am not able to open the report, as it has error while generating it. (Please see the attachment for more information)

Another thing, On the Report Wizard, in the finally step, I would prefer the text of the “Cancel” button would change to “Close”, I think it is more suitable after generating the report. (This also apply to Reverse-Engineering Wizard) as “Cancel” would mean Interrupt and Close mean exit the wizard…ect

Please let me know if you want me to explain more.

Many thanks


Message was edited by: Chi

errorexcutereport2time.doc (50 KB)


Hello Chi,

We have verified this issue - selected to generate RTF report, generated successfully, “accidentally” clicked Execute again. The report was generated again and finally a message “Report was generated” appeared. We repeated this several times - on RTF and HTML as well. The same report was always re-generated and no error occured.

Can you simulate the problem once again? Does the problem repeat?

In any case, our testers will further deal with it.

I would prefer the text of the “Cancel” button would change to “Close”,…

A few comments on this:

  1. I can click Cancel in every step in the Wizard to quit it.
  2. When I click Execute, the Execute button becomes disabled. The process is running. If I click Cancel now a notification appears: Report generation in progress. Do you want to terminate it? Yes - Wizard closes, No - the process continues.
  3. After the report is generated, I can generate another report - and while doing it, Cancel may come in handy again.
  4. If I know I will not generate another report, I can select Close Wizard after Execution check box before I start the generation.

Back to 3. - I think there’s no use to change Cancel to Close for the moment when you decide to generate another report or not, and if click e.g. Previous, change the Close button to Cancel back. (I’m not sure if I explained it clearly.)
I have an option to select the check box (see 4.) or simply click x to close the Wizard.

Also, I think there are already enough buttons in the Wizard to add another one for the close.

If you have any remarks, please write me back. Thanks.



Hi Vladka

I get the same problem, sometime on the other computer, i think the problem occur more often on low resource/old computer (E.g. better CPU/RAM …etc).

I agree with you about the no use to have extra button for close. Thanks for your explaination

Many thanks

sameproblem.doc (244 KB)