Toad World® Forums

Problem on using Alter script


#1

Hi

I have received some random error after I completed a reverse engineering, when I changed the name of the Model, an Error pop up(“Internal Error – Script engine activation error”) see screen shot 1, fortunately the name of the model can be saved.

Then when I try to use Alter script/merge script function an other error occur, please see screen shot 2. that error occur quite often now,but after the error occur, the action that I want to do still been process.

I am not quite sure how to explain the error I receive, because it just display an error pop up, but it does not stop the process. (It always display the error message when I try to merge 2 model together. it is quite annoying) I am using windows vista, and reverse 2 Mysql model

Many thanks

Chi

Please see the attachment for more information

Message was edited by: Chi
TDM Error.odt (184 KB)


#2

Hello Chi,

Just a quick update to inform you that we are dealing with this issue.

  1. Random error after renaming reversed model - I keep failing to reproduce the problem. I’ve forwarded it to our testers for further verification.

  2. Error in PERAttributeMY
    I’ve forwarded it to our developers. CR # 47 440. As soon as I have some news, I’ll let you know.

Thanks for your patience.

Regards,

Vladka


#3

Hello Chi,

Referencing to the error during renaming the reversed model.
Chi, could you please write us how/where you renamed the model? In a Stamp properties, or in Model Explorer, Application View pressing F2, Model Properties…?

Thanks.

At the moment we’re testing whether it’s connected with Vista…

We look forward to your reply.

Regards,

Vladka


#4

Hi Chi,

Thanks for your email. Unfortunately, my Outlook seems to have extended weekend today. :wink: So, I’m contacting you via our community.

Thanks very much for your information and screenshots.

I and our testers have gone through the whole process again, trying to simulate the problem during the model merge. For now we were not successful.
Weve checked out your screenshots again, and from the information you sent us, we do suppose, you like to update an existing MySQL model in TDM3.

Please find attached a doc where I describe the steps we’ve taken. Are they the same as yours? Please see my notes in the doc as well.

Thank you very much.

Additional Note: Unfortunately, the description of the error message is in Chinese. Please send us your models so as we can get English version of the error description. It would help us. Thanks.

You can send the info to my email address or to modeling@quest.com. (I do believe the problem in Outlook will be resolved soon.)

I look forward to hearing from you.

Kind regards,

Vladka + TDM Team
MySQL_Merge_problem.pdf (212 KB)


#5

Hi Vladka

The different of what I done is, I create the model on TOAD (called ModelTDM) and use the SQL script to generate the database after a few week, I modify the model on MySQL and ModelTDM, then I reverse-engineering MySQL model and Rename it as REModel. Then I preform the Alter/Merge/Compare the model. then the error occur.

Today I have followed your instruction and prefer the merge model method, I have not receive any error. I guess it is because I have saved the model this time. then the problem does not occur again.

The Error message is about:
Source: Microsoft JScript execution error
Script: PERAttributeMY
Description: Object not support this property or Method

So If my assumption is correct, I am wondering if it is possible to allow merge model without the need to saving the reverse-engineering model.

Please let me know if you want me to explain more.

Many thanks

Chi


#6

Hello Chi,

Thanks for your reply.
This time, I didn’t save the reversed model(s) and launched the model merge straight away. No problem occurred.

I’m not sure what TDM version you use. Please download the new patch v. 3.1.7.36. Please check out the problem there. I do hope it will work fine for you.
(New Beta 3.2.1 will be released this week.)

Note:
Another TDM user encountered the same error, however after taking other steps. What he did: He reversed his MySQL database, he made change in entity and when he tried to save the change in this .txp file, this error occurred:
Source: Microsoft JScript runtime error.
Script: PERAttributeMy
Description: Object doesnt support this property or method.

Here is what solved his problem, let me quote the customer:
“I installed TDM on a different machine and the error was non reproducible. In order words this does not seem to be an issue purely based on TDM but rather on my specific machine and TDM.
I then did a fresh clean install of windows and all the tools I use on my own lap top and have not received the error since.”

Chi, could you please check out whether this problem occurs also on another machine? Thanks very much.

Just a note on the subject name - “Problem on using Alter script” (for readers):
We discuss model merge in this thread in fact. It is not possible to generate alter script for MySQL db (only for Oracle db at the moment.)

Kind regards,

Vladka

Message was edited by: vladka - added note on the subject name


#7

Hi Vladka

Thanks for your information.
The version that I am using is Beta 3.1.6.11.
I guess it is probably something wrong with my computer. Anyway I do not think I am going to do install my windows again, as it is quite a big task. I hold the latest release could solve that problem.

I am wondering if it is possible to download the Trail Version to TDM 3.1.7.36 and put my liscence key on it and activate it?

Or I have to login to the account that I order TDM and download a copy from there?

Thanks very much for your help

Chi


#8

Chi,

please check out the problem in latest Beta 3.2.1 that has just been released.

I am wondering if it is possible to download the Trail Version to TDM 3.1.7.36 and put my liscence key on it and activate it? Or I have to login to the account that I order TDM and download a copy from there?

Trial version and commercial version are in one installation package. If you have a valid license key for commercial version and just downloaded latest version 3.1.7.36, the application should open automatically, no key should be required and previous commercial version should be updated automatically.
You can install the trial version from:

Regards,

Vladka