Toad World® Forums

Problem with dot lookup


#1

if you do this

select cnfr_intr_no from trex_cnfr_requests cr WHERE cr.

and you wait for the dot lookup to come up, it ONLY gives you the cnfr_intr_no column, NONE of the other columns!

[:(]

BTW, this new forum is hard to read.


#2

Hi Joe,

Thank you for reporting this. I could see the same dot lookup problem with you too.

PT#52766335 has been raised for it, once we fix will let you know.

Thanks again,

Shirly


#3

BTW for the new forum, we have same feelings with you too. We have tried to give some feedback to Toad Community team already, I believe they are still on the way to make it better. If you have any concern, you can email to let them know too, thanks.


#4

Also, when looking up tables it appears that the first time you try it in a session (i.e. before you execute any queries) it won’t find any tables.


#5

Hi Joe,

Do you meant that first time try to lookup schema.table after new a seesion? If so I couldn’t reproduce it, the tables display as expected for me.

Thanks,

Shirly


#6

Hi Joe,

We have fixed the dot look up issue for query like: “select cnfr_intr_no from trex_cnfr_requests cr WHERE cr.” already, please check in next drop, thanks.

BTW the last issue you reported, did you still see it?

Thanks,

Shirly


#7

This is still busted. I’m using 7.0.0.2933


#8

Hi Joe,

This will be applied in next drop after 2933, we plan to post a new build this week to community, will let you know then Joe.

Thanks,

Shirly


#9

Hi Joe,

This dot look up issue has been fixed and applied in our latest beta 2962.

You can download and have a check from:

www.toadworld.com/…/19982.aspx

Any issue please let us know, thanks.

Thanks,

Shirly


#10

Yes, these seem to be working now. It does seem to take a long time to find tables the first time you do something like “select * from all_” and then wait for the suggestions. Must be loading table names into memory or something.


#11

dot look up doesn’t work on inline views


#12

Hi Joe,

Can you please send us the inline view query you are using which has issue with dot look up? I tried one below and it works for me:

SELECT a.last_name, a.salary, a.department_id, b.maxsal
FROM employees a, (SELECT department_id, max(salary) maxsal
FROM employees
GROUP BY department_id) b
WHERE a.department_id = b.department_id
AND a.salary < b.maxsal

Thanks,

Shirly


#13

hmmm it’s flaky. sometimes it works as expected and sometimes it doesn’t. I’ll try to get an example the next time it doesn’t work as expected.


#14

For example, this doesn’t seem to work:

DELETE all_objects x WHERE x.


#15

Thank you, PT#54493556 has been raised for it.