Toad World® Forums

problem with log in to db as OID user more than once


#1

I’m using 6.0.0.733 beta build.
I’ve got two databases: SAMPLES and BAZA, both are registered in OID.
In case of BAZA I’ve got schema user KMTEST2 which is mapped to enterprise user K.
I’ve tried to follow these steps:

  1. Open sqlnav
  2. Login as K to database BAZA, connection was established
  3. So I’ve tried to log once more as user K to database BAZA and I’ve got error shown in the attachment.
  4. So I’ve tried to log in using sqlplus as K to database BAZA and connection was established.

In the begining I’ve mentioned that I’ve got two databases because suprisingly the error isnt occur when I’m trying to create multiple sessions to database SAMPLES.

The only diffrence between these databases is that: they are member of diffrent enterprise domains (this is still the same realm).

sqlnav_bug.jpeg


#2

Hi Chris,

Thanks for your feedback.

Are there any differences between the user K and the other user that you managed to make multiple connections to SAMPLES (in sqlnav) in terms of access rights ? Also, would it be possible to pass us any trace logs that you may have when attempting multiple connections to BAZA ? Thanks.

regards,

Bernard


#3

Hi Chris,

One more quick question. Are you using the Oracle 9i OID or the Oracle 10g App Server OID ? Thanks.

regards,

Bernard


#4

I’m using OID which was installed as part of Oracle Application Server 10g release 2 (10.1.2).


#5

I’m sorry about confusing but I’ve discovered that the problem is not connected with OID at all !

I’ve unregistered database from OID and try to create multiple session using simple TNS names and users SYSTEM and the problem was the same.

Moreover I’ve tried to create multiple session from sqlnavigator installed on the same machine as DB and it works fine.

I will try to test the issue from diffrent computer than mine and database komputer.


#6

I’ve tried from two diffrent computers and the problem exist in each of them.
The problem occur only with the one specific database BAZA with another databases I can create multiple sessions without problems.

Moreover I had to change the routing table and arp table on my computer in order to communicate with the database server. I’ve done that with these commands:
arp -s IPnumber MACnumber
route ADD IPnumber MASK 255.255.255.255 myIP METRIC 3

These special actions were required because this server is not part of
windows domain.

The situation is very specific so I think we dont have to continue tracking this issue. I’m sorry for confusing once more.

Best regards


#7

Not a problem Chris,
Thanks for updating us with your findings…
We look forward to receiving more SQL Nav feedback from you in the future.

Jaime