Toad World® Forums

Problem with query positioning2

I have a problem similar to Joethjet’s “Problem with query positioning”. If you have a bunch of SQL statements in the editor, and you want to run them one at a time, you used to be able to press F8 to run the first one, (see the results), then press F8 again to run the next query, and so on all the through all the statements. This does not work anymore.

Thanks.

-Charlie

Hi Charlie,

Thank you for your feedback.

We reproduced this issue and fixed it with the issue Joe raised “Problem with query positioning” together in PT#53930795.

F8 should work as expected now in our latest beta build 2962, and the query position as well. Could you please have a check and confirm the issue doesn’t exists anymore for you? You can download it from: www.toadworld.com/…/19982.aspx

Any issue please feel free to contact us, thanks.

Shirly

This is not fixed for me. After you press F8, it runs the statement, but the cursor does not move. In previous versions, if there were multiple SQL statements, I could press F8, it would run the first statement, then press F8 again, the next statement runs, F8 again, the next one runs, etc. Now, when I press F8, the first statement runs, then press F8 again, it runs the same SQL statement. It doesn’t move. It used to.

Thanks.

-Charlie

Hi Charlie,

Thank you for your feedback.

Firstly I would like to suggest you do a new reply rather than editing the last one. It’s because we will not get any notice if you edit your last reply, and most of the time we will not look at the old post which has been worked out, in that case we may miss what you updated. [:)]

For the F8 issue, before you do F8, did you select the sql or just put the cursor in? If you selected the sql and do F8 it will run this sql, F8 again if the sql is still selected it will NOT jump to the next one. That’s as expected behaviour if you keep that sql selected. Try to just put cursor in the sql, and do F8 and F8 again it should work for you.

Let us know how you go, thanks Charlie. [:)]

Shirly

I am not selecting the query, i just have my cursor in it - but it still stays on the first one.

Paste the following, then go on the first one and press F8. It runs it. Then you should be able to press F8 again to run the next one, but it doesn’t, it stays on the first one.

SELECT * FROM DUAL;

SELECT * FROM DUAL;

SELECT * FROM DUAL;

SELECT * FROM DUAL;

Thanks.

-Charlie

Sorry Charlie we still couldn’t reproduce it. [:(]

Could you please confirm the build you are using is 2962 for sure? Please make sure you download via this link: http://toadsoft.com/sqlnavigator/beta/2962/sqlnav_7.0.0.2962-KX_beta.zip (114mb) rather than download from the DOWNLOAD button in overview tab, because the DOWNLOAD button hasn’t been updated yet.

Any issue please let me know, thanks.

I’m positive I am running beta 2962. I’m surprised you can’t reproduce it. It is easily reproduced on my end. Maybe I’m not explaining the issue right. Let’s try this.

Paste the following.

SELECT ‘1’ FROM DUAL;

SELECT ‘2’ FROM DUAL;

Click on the first line so the cursor in on the first query.

Press F8. In the grid you will one row with ‘1’ in it.

Press F8 again (do not click anywhere). You should see ‘2’, but you don’t. ‘1’ is there again because it ran the first query again. Previously, you could run through a whole list of queries one at a time, by only pressing F8.

I hope this is clear.

Thanks.

-Charlie

Hi Charlie, from what you said looks simple to reproduce. But almost every one in our team has tried the exact steps as you did, no one reproduced it. Not sure what the problem is. Could you please send us your profile for further check? Thanks.

Main Menu | Tools | Profile Manager | backup

Then send the file to: shirly.nie@quest.com.

Thanks,

Shirly

When I go to /Tools /Profile Manager, I get this error (attached).

-Charlie
Capture.jpeg

I have the same problem. Something is different about our releases. Maybe you should upload the file again.

Yeah, something was a little weird. I un-installed and then re-installed (the first time I just installed over the previous beta). This is working now - although, you can’t see the cursor. It does step through each query like expected. It would be nice to see the cursor (on the query it will run), but at least it is working now.

Thanks.

-Charlie

Hi Charlie,

Good to know that it works for you now.

If you want to see the cursor in scripts, please turn on this option: Preference | Code Editor | SQL Scripts | Cursor focus stays in the scripts after execution. With this option on, cursor will stay in scripts rather than data grid. But what I need to tell is, the cursor will jump to the beginning of next query if you use F8, which is as expected.

Any issue please feel free to contact us, thx.

Thanks,

Shirly

I have a correction to make. This is still an issue. It didn’t start working after the re-install. Well, it did, but not because of the re-install. I have it narrowed down to a Profile. I have two separate profiles. With one profile, it works perfectly. With the other profile, it does not work. Do you want me to send you the profiles or upload them here? They are about 5MB each.

-Charlie

Yes please Charlie. You can upload it here or send it to my email directly, anyway you like would be ok, thanks.

shirly.nie@quest.com

Thank you for your help,

Shirly

Hello,

I have the following formatting problems in the last beta release 7.0.0.3022:

  1. If I try to run a script in more steps when I press the F10 button (skip to next step) enables the cursor to the file menu and then prevents me from performing the function F8 next steps.

  2. If I try to move or indent a block of code with the TAB button this deletes the entire selected block while unindent (shift + tab) works correctly.

Thank you very much for your support.

max

Hi Max,

Thank you very much for your feedback.

I can see the 2 problems you reported in build 3022, PT#58405262 has been raised for them, once we fix will let you know, thanks.

Thanks again,

Shirly

Hi Max,

We have fixed the F10 and Tab (delete text) issues you reported.

Please refer to our product support site for the download link.

Thanks and regards,

SQL Navigator Team