Toad World® Forums

Problem with substitution Variables.


#1

A couple of things:

  1. In 5.5 in remembers my last setting for substitution variables. I.e., should the editor prompt me for the value or not. 6.0 doesn’t seem to do that.

  2. That’s mostly an annoyance, but if I come into sql nav (or open a new file to run) and forget to click on the :& I get an error ‘Encountered the symbol “&”…’ BUT, even if I click on the :& I continue to get the error and I have to exit sql nav to reset it.

Jet


#2

I assume the newest build that you got from us already have these issues fixed. let me know if there’s anymore problem.

Gwen


#3

Hi Gwen,

Sorry, but it’s still a problem.

Jet


#4

Hi Jet,

  1. what do you mean by 5.5 remember your setting for substitution variable? Were you talking about the feature being turned on or that if it see the same variable it wont prompt you again?

  2. this one does not happen to me at all. It does display error the first time, but as soon as the button is enabled, it prompts for input.


#5
  1. In 5.5, if, when I was last in Nav, I had the button for Sub Vars pressed, when I exit and come back in, it’s still on. in 6.0 it’s always off.

  2. Well, i don’t know what to tell you because I get the error. Are you using 879? i get an ora-01008, not all variables bound. And, it won’t go away until I leave nav and reenter. If you want to webex and watch, I’m fine with that.

Jet


#6
  1. I had a long discussion with Bruce about remembering the setting for SUb var as well as some buttons on the Code Editor toolbar. If we fix Nav so that it saves the setting for sub var, we have to consider other buttons as well. However, some customers may not want the other settings to be saved because having them on may affect the performance of Nav or other reasons. (think fetch all or stop on error). So we will consider this in the future and maybe add a preference for it. Btw, the workflow for 5.5 is not perfect (it only remembers the setting if you close the editor. in the case of open a new editor or close Nav, it doesn’t work)

2.I also get the ora-01008 and it prompts me right after I clicked the button. webex please! :smiley:

Gwen


#7
  1. well, I guess I’m thinking that most of your customers are going to be continuing Nav users so the product should work very much the same or you’re going to confuse people. In this case it works different. If that means saving all the buttons then…well, it’s nothing new for you guys. And, you’re right about fetch, but I believe it’s still a preference that you can select (and forget about!)

  2. We should make a list of things you want me to show you first. Please email me directly and we can get things arranged. I assume you guys have web ex?

Thanks,

Jet


#8
  1. We will definitely look into it in the future.

  2. We do have webex but it may take a while to set up. For the time being, can you please post the SQL statements that you were using?

I keep you posted

Gwen


#9

Has to be in a sql script:

declare
stuff varchar2(30);
begin
select owner into stuff from all_objects where owner = &1 AND ROWNUM < 2;
end;


#10

Hi Jet,

We have identified the problem. This particular piece of code somehow broke the substitution variable function.

I first tried to run a statement like:

select owner from all_objects where owner = &1;

and it works as expected.

after I run the statement you supplied, the function broke. Nothing works.
We will fix it as soon as possible. For the time being you may want to avoid PL/SQL block. (the functionality will come back if SQL Nav is closed )
Thanks for your helpful feedbacks,
Gwen