Toad World® Forums

Problem with Verify Model




Maybe I’m missing something or maybe this is just a minor bug, but when I use the Verify Model function, I get “duplicate NOT NULL Constraint Name” errors. The issue is, my constraints use to be NOT NULL on those columns, but has long been removed. When I put the NOT NULL constraint back, I see it still uses the same original name.

Maybe the verify model functionality should just exclude the nullable fields from that specific check?



Hi Rudi,

Yes, it is a small bug. Thanks for your notification. Although Not Null is disabled and the Not Null Constraint tab in the Attribute Properties dialog is not displayed, the name of the constraint (provided that you did not delete it before) remains remembered by TDM. We will fix it. CR # 67 519.




Message was edited by: vladka


Hi Rudi,

We have made a workaround until it is fixed.

Please find attached a package with macro that will automatically go through all attributes in your model and where it will find unchecked Not Null box, it will check out if the Constraint Name box was previously filled out or not. If it was, it will automatically delete the name. During Model Verification then, no such message will be returned.

Please copy the .txg file to the location where you store user packages. Default location is:
C:\Documents and Settings\user\My Documents\Toad Data Modeler\Installation name\Packages{DCB5CB9B-CF65-4350-86B5-285D246FC5AC}.

Run TDM.
Uncheck NotNull for the attributes that you want and then select Macros | All | Remove Hidden NotNull Constraint Name macro. See the Message Explorer for details on the process.

Note: The Macro works for Oracle models only.

If you have any questions, please write us back. Thanks.


Vladka + Mario

Message was edited by: vladka - added note (1.33 KB)