Toad World® Forums

Q## clearup


#1

Hey

I have created a new test using the test manager.

The test is testing a recordset return against a query.

It seems to work.

However when I want to change the query of the test, a new underlying Q## object is created in the test schema. This is fine but the old Q## object is left behind.

I have tried to get the system to clear this up be re-generation. To no avail.

I can manually remove the creation from the “External initialization for all unit tests” code but I don’t feel this is the correct way to do it. I also tried pressing the “Refresh custom logic” button. This appeared to do nothing as well.

Any ideas?

Thanks in advance.


#2

Yes, I have a FINE idea: in 1.2.6 and above, that package will no longer be created. Instead, it will be part of the test package, and we will only create nested table and object types. These WILL be cleaned up when you delete the test definition.

I hope to put out 1.2.6 within the next two weeks.

Regards, SF


#3

Excellent suggestion - thanks. I am becoming a major fan of this tool. We are going to incorporate it into our project and insist all PL/SQL unit tests be written with it.