Toad World® Forums

Query exports in improper nls format ...


#1

Hi there it’s me again.
Saving query to file. Date formating works badly.
Results are saved in displayed format but not in selected in export

properties. When exporting as “table insert” with “apply NLS …” setting

enabled, format of to_date conversion is formed badly too.
for example : to_date(‘2006-01-01’,‘YYYY/MM/DD’)
Check it out.

Regards Piter.


#2

Hi Piter,

I will discuss with Andrew and Roman on this and we will get back to you with more info Monday.

Thanks,
Bruce


#3

Hi Piter,
Bernard has fixed the issue with format of the date when exporting data from the SQL Edit result. The changes will be the next beta buil to be released next week.

Thanks,
Bruce


#4

Great to see this! Thanks


#5

Hi!
Bad news, in beta 4 release, query still exports in inproper format. Some nls formats works ok but try to save as YYYY/MM/DD format.
It will be :
(‘2006-07-15’,‘RRRR/MM/DD’).

Formats with “-” works OK, but with “/” not.

Regards Piter.


#6

Thank you very much Piter for the feedback. Bernard will revisit this again for you and will get back to you early next week.

Thanks,
Bruce


#7

Hi Piter,

I have investigated your issue and managed to reproduce it (after setting Windows to the Polish locale). In my case, the inconsistency in the presentation of the date separator in the export script was due to all the date formats in Preferences (please see prefs.bmp) using “-” as the date separator.

I have a workaround that you may be interested to try…please set your date seperator to “/” as I have done in my attached screenshot (regional_options.bmp). This should cause the list of date formats in Preferences to have a mixture of “-” and “/” (eg. “7/17/06 (MM/DD/RR)”, “17-lip-06 (DD-Mon-RR)”). When you do an export, the presentation of the date separator should be now consistent.

So do let us know how you go with the workaround, thanks.

FYI, we will be investigating the possibility of making the date format selector in Preferences editable in the future (which will help resolving issues like this).

regards,

Bernard


#8

Hi Piter,

I have investigated your issue and managed to reproduce it (after setting Windows to the Polish locale). In my case, the inconsistency in the presentation of the date separator in the export script was due to all the date formats in Preferences (please see prefs.bmp) using “-” as the date separator.

I have a workaround that you may be interested to try…please set your date seperator to “/” as I have done in my attached screenshot (regional_options.bmp). This should cause the list of date formats in Preferences to have a mixture of “-” and “/” (eg. “7/17/06 (MM/DD/RR)”, “17-lip-06 (DD-Mon-RR)”). When you do an export, the presentation of the date separator should be now consistent.

So do let us know how you go with the workaround, thanks.

FYI, we will be investigating the possibility of making the date format selector in Preferences editable in the future (which will help resolving issues like this).

regards,

Bernard


#9

Hi
I checked that situation, so my settings looks like this:
Preferences:
Date Displayed Format : YYYY-MM-DD
Default Date Format : YYYYMMDD

In System variables i changed from YYYY-MM-DD to:
YYYY/MM/DD

And It helps! Now I can export with “/” or with “-”.
So it looks like Win date variable must be set as seperated by “/”, and “Date Displayed Format” in pref. can be set with any separator.

Is there any posibility to fix that issue for date with “-” sparator?

Thanks and regards Piter.


#10

Hi Piter,

We have target the changes to allow you to have full control on the display format of dates in Nav preference screen, ie the list selection field will be editable, currently it is a fixed list of items. As we are currently in System for 5.5 release, and there are risks involved with the changes, ie we will try to get this fix for you in a post 5.5 Beta build very soon .

Thanks and regards,
Bruce


#11

Thanx a lot!